Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Nautilus Columns (Nautilus extension) in Ubuntu 12.04 64bit and after installing it I can't open Nautilus it just Crashes/Closes when I try opening it.

This is the message I get from the command line when I run Nautilus :

Initializing nautilus-ideviceinfo extension
/usr/lib/python2.7/dist-packages/gobject/constants.py:24: Warning: g_boxed_type_register_static: assertion `g_type_from_name (name) == 0' failed
import gobject._gobject
Traceback (most recent call last):
File "/usr/share/nautilus-python/extensions/arista-nautilus.py", line 38, in
import nautilus
ImportError: No module named nautilus
Initializing nautilus-dropbox 0.7.1
TypeError: metaclass conflict: the metaclass of a derived class must be a (non-strict) subclass of the metaclasses of all its bases
Segmentation fault (core dumped)

Does anyone have any ideas because I would like to get this working.

share|improve this question
    
independently of the answer you get here, please file a bug report. –  xubuntix May 17 '12 at 6:20

2 Answers 2

After a suggestion from another user named Andrew he suggested I uninstall Arista due to something in the output in the command I posted and the Nautilus and Nautilus-Columns worked fine together. I also reinstalled Arista and didn't get anymore crashes with Nautilus as well

share|improve this answer

According to the PPA here

nautilus-columns

It is unclear whether it is compatible with Precise . Please file a bug report by following this.

share|improve this answer
    
Please post your solution as answer in detail , and accept it as answer. It will help others having same problem. –  atenz May 17 '12 at 18:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.