Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a G73JW laptop using Ubuntu 12.04. It has an Atheros AR9285 card.

While wifi seems to work fine most of the time, about every hour or two it will loose the connection to the internet. The connection will appear to be connected still to the wireless router, but internet access is gone.

Disconnecting and reconnecting to the access point solves the problem, as does disabling and reenabling the adapter via the hardware keyboard shortcut.

How might this be solved so the connection is stable and doesn't drop?

EDIT: It looks like the network dropping isn't related to DNS as it fails either way:

codyloco@CodyLoco-Ubuntu:~$ dig askubuntu.com @8.8.8.8

; <<>> DiG 9.8.1-P1 <<>> askubuntu.com @8.8.8.8
;; global options: +cmd
;; connection timed out; no servers could be reached
codyloco@CodyLoco-Ubuntu:~$ dig askubuntu.com

; <<>> DiG 9.8.1-P1 <<>> askubuntu.com
;; global options: +cmd
;; connection timed out; no servers could be reached

Again cycling (disabling / enabling) the adapter corrects the issue.

share|improve this question
    
This sounds as though you might be losing your DNS server configuration. The next time it happens would you please try these two commands in a terminal? First do dig askubuntu.com @8.8.8.8 followed by dig askubuntu.com. –  irrational John May 17 '12 at 22:44
    
@irrationalJohn I'm still working on this -- as soon as it happens again I will do it- it has happened a few times since but stupid me didn't have this page open to be able to see what the commands are! –  CodyLoco May 30 '12 at 14:07
    
@irrationalJohn I've updated the question to include the output of the dig command as you requested! :-/ –  CodyLoco Jun 1 '12 at 15:55
add comment

2 Answers

I ran into comparable issues after I updated the configuration of my access point to "auto channel = ON": it checks the best wifi channel every X hours, and switches to it automatically.

share|improve this answer
add comment

You might want to keep an eye on:

http://linuxblog.avserver.info/how-to-fix-wireless-problems-in-ubuntu-1204-precise-pangolin/

I have the same card (on a Sony VAIO VPCEB1Z0E). I started getting those disconnections about 6 months ago - oh, right after upgrading to 11.10. I upgraded to 12.04, and it's hardly helped! Now, I regular find it thinks the device is turned off at the switch - to fix that I have to do

sudo rfkill unblock wifi

Finally, even when things are working - the connection is at things like transfering files via SSH, or forwarded VNC connections.

share|improve this answer
    
Thanks -- but has become too much of a pain. I've ordered an Intel 6235 card that will hopefully work better, I see tons and tons of posts here on AskUbuntu with problems with this card and to be honest it took me months to get it working properly even in Windows 7... so I'm hoping the Intel card will be rock solid. Appreciate the help @David –  CodyLoco Jun 5 '12 at 14:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.