Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a fully updated Ubuntu 12.04 and my Dell laser class 1130n printer won't install via a USB port. Does anyone have any ideas? It says that I have the wrong driver and it only prints an error page.

share|improve this question
1  
Nevermind, I forgot that I could use the 'generic' driver, it ended up working. –  Ron May 17 '12 at 2:25

2 Answers 2

Ubuntu does not include a driver for your printer.

A google search tells me that Dell's 1130N is actually a rebadged Samsung ML-2580n with customised firmware. What generic driver did you actually use? Paste the output of this command on a terminal: grep -H '^*NickName:' /etc/cups/ppd/*.ppd

Can you try weather the splix driver for the Samsung ML-2580N, which is included with Ubuntu, works good or better than the generic driver with your printer? Go to system-config-printer (System -> Administration -> Printing in GNOME classic, Gear icon at the upper right of the screen -> Printers in Unity), right click your Printer and select Properties > click Change... next to the Make and Model field to see the available drivers and change it to Samsung ML-2580N.

share|improve this answer

We also have 12.04 and tried installing our Dell 1130 on it. It had worked with 11.10 but we could not do so with 12.04. To make a long story short we found that someone in another forum found that if you chose the Samsung ML1915 from the manufacturer list instead of the Dell 1130 that it worked just fine.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.