Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to establish a VPN connection on 12.04. It had worked in 11.10 but not at all right now. I can connect with Windows 7. My roommate also recently upgraded and is having the same problem.

Here is an excerpt from my system log: http://paste.ubuntu.com/991558/

We would appreciate any help!

UPDATE: I have tried recreating the connection and allowing MPPE encryption. My roommate found that he is able to get a VPN connection at another location. Is it possible that this has something to do with the way Ubuntu is communicating with this specific (and, I forgot to mention, new Buffalo) router, while Windows has no issues at all?

share|improve this question
    
try to configure what I described in my updated answer, you might be lucky :D –  vicd May 19 '12 at 5:11

5 Answers 5

If it's a password protected VPN, you should try:

  • open "Network"
  • select your VPN > Configure > VPN
  • Change the password dropdown to "saved" and type your password in that field
  • Save + try

For some reason the "Always Ask" option doens't seem to work (for me) in 12.04.

share|improve this answer

I had the same problem. After upgrading my machine was showing two Ethernet connections, which it does have, Once I deleted one of the Ethernet connections the VPN connections feature showed itself again.

share|improve this answer
  1. make sure your vpn server is running

  2. don't forget to the check "Use Point-to-Pont encryption(MPPE)" in PPTP Advanced Options Dialog in Ubuntu 12.04

UPDATED ANSWER:

I checked this issue again today, and here is my point: if you get your ubuntu running in a virtual machine(VirtualBox for example), you should configure the Networking setting to "Bridge", DO NOT use "NAT". Otherwise, you may encounter this similar error logs and fail to connect to your VPN Server

19 00:58:11 ubuntu1204 NetworkManager[449]: <warn> error disconnecting VPN: Could not process the request because no VPN connection was active.
May 19 00:58:11 ubuntu1204 NetworkManager[449]: <info> Policy set 'Wired connection 1' (eth0) as default for IPv4 routing and DNS.
May 19 00:58:16 ubuntu1204 NetworkManager[449]: <info> VPN service 'pptp' disappeared

Hope this helps

share|improve this answer

Go here and scroll down to where it says "VPN setup using the command line."

This helped me solve my problem in 12.04 and I hope it helps you as well.

share|improve this answer
1  
Welcome to AskUbuntu! You may want to add the useful information of the link you posted so if it gets modified or deleted your answer will stay relevant and complete for future users. –  Oyibo Oct 3 '12 at 7:21

Deleting and recreating the VPN connection configuration has worked for me in the past.

share|improve this answer
1  
This is really a comment, not an answer to the question. Please use "add comment" to leave feedback for the author. –  Stephen Myall Aug 15 '12 at 8:09
    
@amfcosta Even though many users may know, it may still be considered valuable for you to expand this answer to explain how to delete and recreate the VPN connection. –  Eliah Kagan Aug 15 '12 at 21:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.