Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Ubuntu 12.04, with both PCManFM and Nautilus installed.

I've succesfully set the default file manager to PCManFM: I've accomplished that by doing the following steps:

  • Right-clicking a directory - Open With... - choose PCManFM
  • Choosing PCManFM as the file manager in exo-preferred-applications
  • Running mimeopen -d ~/Dropbox, and choosing PCManFM

Right now, every folder I open, opens in PCManFM. This is what I want. However, when I click the Dropbox icon in the upper bar of the screen, and then 'Open Dropbox Folder', Dropbox will be opened in Nautilus instead of PCManFM. Is there any way to force Dropbox to open it in PCManFM instead?

share|improve this question
    
Check this out. How can I integrate Dropbox with PCManFM? –  Basharat Sialvi May 16 '12 at 20:14
    
Thanks, but I already applied that, without success. You're right that I should've mentioned that in the question. –  Exeleration-G May 16 '12 at 21:04
1  
just to clarify your question - you are using Unity with PCManFM as your filemanager, you are NOT using lubuntu/lxde with the default PCManFM? To help others out with how you set PCManFM as your default filemanager in Unity, perhaps add this link (or info) into your question. Thanks. –  fossfreedom May 16 '12 at 22:40

2 Answers 2

In my experience (described in greater detail here):

  • If Nautilus is installed, clicking on the Dropbox tray icon or on the "Open Dropbox Folder" menu item will launch Nautilus regardless of other settings.
  • If Nautilus is not installed, the Dropbox daemon will look for your "inode/directory" mimetype.
  • If Nautilus is not installed and "inode/directory" mimetype is not set, the default browser (i.e. the preferred "x-www-browser") will be launched.

P.S.: As a quick and dirty workaround, you might wish to create a script with, say, the following code

#!/bin/bash  
exec your-favorite-file-manager $@  
exit 0  

call it 'nautilus' and place it somewhere in your $PATH.

share|improve this answer
    
Have tried the quick and dirty workaround, but nothing happens when I use the 'Open Dropbox Folder' menu item. Typing 'nautilus' at the command line does execute my alternative (dolphin). –  EoghanM May 2 '13 at 12:40
    
@EoghanM, if you placed it in a place like ~/bin, then it is only accessible from a command line. You might think of placing the script (or a symlink pointing to it), say, in /usr/bin. –  Vitalie Ciubotaru May 9 '13 at 7:16

Uninstalling Nautilus worked for me.

If you want to keep Nautilus, I think the issue is similar to setting the default file manager for Firefox, and there is more info available about that, for example here: How to set up Dolphin as default file manager?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.