Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My problem is that when I log out from a gnome shell session I get a blank screen instead of the display manager. If I close the lid to suspend and then open it again, I get the display manager and I can log back in.

This does not happen with Unity. When I log out from a Unity session I get the display manager without any problem.

I'm running Ubuntu 11.10 64bit, with gnome-shell version 3.2.2.1. I already checked /etc/X11/default-display-manager, and it's set to /usr/sbin/lightdm, as it should be, according to this post: http://askubuntu.com/a/84485/61336.

This is the exact same problem described here Ubuntu 11.10 with Gnome Shell does not logout properly, but as you can see, I provide some additional information. I tried to leave a comment in the original question to avoid a duplicate, but I don't have enough reputation. I also tried to ask in the meta section what to do in order to avoid a duplicate in this situation, but again, not enough reputation.

share|improve this question
    
Please post the installed Gnome shell version. –  tijybba May 16 '12 at 19:51
    
My gnome-shell version is 3.2.2.1 –  cantillon May 16 '12 at 22:53
add comment

2 Answers

If you are using Gnome 3.4 then be ready for it because 3.4 is not fully supported by 11.10 You will have broken packages,etc.

I have experienced it on my 11.10 and now also experiencing the Awesome performance with no problem in 12.04

Also you can try reconfiguring lightdm by entering the following command in the terminal:

sudo dpkg-reconfigure lightdm

Hope it solves the issue.

share|improve this answer
    
Thanks for your answer. I tried reconfiguring lightdm as you suggested and it didn't solve the problem. Besides, I get this message: dpkg-maintscript-helper: warning: environment variable DPKG_MAINTSCRIPT_NAME missing dpkg-maintscript-helper: warning: environment variable DPKG_MAINTSCRIPT_PACKAGE missing This message seems to be related to this bug. –  cantillon May 16 '12 at 23:30
    
First check if this file of yours is empty- "/etc/lightdm/unity-greeter.conf". If yes then follow this link. askubuntu.com/questions/66533/… –  Nirmik May 17 '12 at 4:49
    
@ cantillon - it seems to be a bug , please report the bug by following askubuntu.com/questions/5121/how-do-i-report-a-bug. –  tijybba May 17 '12 at 5:47
    
@Nirmik I checked /etc/lightdm/unity-greeter.conf and it is not empty. It looks ok to me. –  cantillon May 18 '12 at 2:00
    
@tijybba I'll report the bug. Thanks for your comment. –  cantillon May 18 '12 at 2:00
add comment
up vote 0 down vote accepted

Since today I no longer have any problem logging out of a gnome-shell session. I guess one of the recent updates must have fixed the issue, but I don't know which one. I reported the bug here, but I'm not sure the report had anything to do with the fix. Anyways, problem solved!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.