Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Since I recently upgraded my IT infrastructure, I decided to use my old laptop as a home server. The problem is that the machine sports a powerful nVidia card that even at idle generates enough heat to stay 80°C hot.

The laptop is a DELL XPS M1710, with a512MB DDR3 nVidia GeForce Go 7950 GTX graphics card. I'm running Ubuntu 12.04.

Given that I control the server via SSH, I thought that maybe I could somehow "turn off" the video card... is this at all possible? If yes, how?

share|improve this question
    
Well...how good are you at soldering? ;) –  Bobby May 17 '12 at 16:44
    
Did you do a desktop install? Does it boot to a graphical login screen? Did you install nvidia proprietary driver? –  Alistair Buxton May 18 '12 at 3:24
    
@AlistairBuxton - I did a regular Pangolin server installation. The only extra bits that I installed manually have been openssh, nginx and sensors-lm. The machine boot to a regular console login prompt. I can't check right now, but I believe the server installed the noveau drivers. –  mac May 18 '12 at 8:46
1  
You might be able to disable it in the BIOS. –  xjonquilx May 18 '12 at 16:30
    
@xjonquilx - Good thinking (or at least: I had the same idea), but even setting the docking station (which I don't have) as primary video, doesn't solve the issue. :( –  mac May 18 '12 at 18:34

2 Answers 2

The nouveau driver doesn't have a good reputation when it comes to power saving, and since it uses KMS it is probably in use even without X running. Try blacklisting it. Put the following in /etc/modprobe.d/blacklist-nouveau-local.conf:

blacklist nouveau
blacklist lbm-nouveau
alias nouveau off
alias lbm-nouveau off

and then reboot.

However, it might be necessary to install the proprietary driver and load up X to get proper power management of the card.

share|improve this answer
    
Thanks for the suggestion. Unluckily, blacklisting the modules per se had no measurable effect, and installing the entire X system is not an option for me... :( –  mac May 22 '12 at 13:17

There are several things you can try. Personally when I installed ubuntu server to a laptop I just closed the lid which disable the display, but had to make sure it didn't turn off the laptop when I did that.

If your savvy enough which sounds like you are .. you could try under clocking your GPU. This probably wouldn't give you any energy savings dollar wise, but this should solve your heat issue.

Also some BIOs have the ability to set what kind of performance you want for your GPU. You could probably change it from there.

Hope this helps.

share|improve this answer
    
Thank you for your input. Closing the lid doesn't solve the problem. On the contrary: it worsens it. The heat-generating bit is not the display but the videocard, which is unaffected by the display turning off. Also, the lid covers the topmost ventilation hatches, so the heat dissipates even less... :-/ Underclocking the GPU seems like a good idea, but unless there is some way to achieve that via software (any pointer? nvidia-smi doesn't seem to be the tool for the job...), the BIOS doesn't have that option. –  mac May 18 '12 at 23:41
    
I found nvclock and managed to underclock the GPU from 200MHz to 16 and the memory from 350 to 100, but while the system is still stable nor the internal sensors nor the external one I applied to the exhausted measured a change... –  mac May 22 '12 at 13:13
    
If this doesn't cool the GPU down and blacklisting the driver I doubt anything would. –  Goddard May 22 '12 at 20:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.