Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu 12.04 on my notebook having kept an old luks encrypted partition on my drive. This partition shows up in the file manager an can be mounted from there into /media/[UUID]. Now I would like to mount this partition during system boot. For that I added

/dev/mapper/cryptohome /home xfs errors=remount-ro 0 2

to my /etc/fstab and

cryptohome UUID=[...] none luks

to my /etc/crypttab

During boot I am asked for the luks password upon which the /dev/mapper/cryptohome is ready.

While I enter the password the mount command seems to be executed concurrently. This leads to a failed mount. I am able to mount /dev/mapper/cryptohome manually shortly after the automatic mount failes.

How can I make mount aware that it needs to wait until the luks password is entered successfully?

Thanks, Philipp

share|improve this question
    
Are you using LVM on top of the dm-crypt device? –  gertvdijk Jan 8 '13 at 19:34
add comment

1 Answer 1

I would recommend you to use a app called “Storage Device Manager”. It automatically mounts the device at boot without any hassle for me. maybe that can work for you. Full article about it can be read here:

http://www.howtogeek.com/60817/how-to-auto-mount-partitions-at-linux-startup-the-easy-way/

share|improve this answer
    
No. Avoid using pysdm for now! –  gertvdijk Jan 8 '13 at 19:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.