Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 12.04 to a pair of Inwin BL Series machines with AMD A4 series CPUs and an Asus motherboard (Asus F1A55-M/CSM, Micro ATX, Socket FM-1).

Install was smooth, but when the machine boots the keyboard does not work at the grub menu, and when it boots the screen goes blank or displays garbage.

I can blindly login and reboot the machine so its obviously running, but video is totally messed up.

Control-Alt-F1/2 does not give me a text console.

I have booted the CD to rescue mode and set grub to text mode, which works... but as soon as the kernel loads I see it change the font and then the screen again goes blank. The keyboard (USB) does not work until the system is booted so I can't interrupt grub to do anything there.

I assume Ubuntu is setting some graphics or text mode that this hardware does not like.

share|improve this question
    
What if you get this error, when you try to save Grub file after mods? "Could not save the file /media/Ubuntu" ... it's a permission issue ... similar problem, so I just thought I'd ask. –  user159412 May 17 '13 at 9:26

1 Answer 1

Since you can't access the GRUB command line you will have to do the following:

When the GRUB menu appears hit 'E'.

Now it will show the GRUB file which you can edit.

In this file change the default resolution to 640x480px (found on line 25) and make the following changed to the GRUB file:

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=off pci=noacpi"
GRUB_CMDLINE_LINUX=""

If it works with this config, go after your system boots up properly, go to terminal and type:

sudo gedit /etc/default/grub

Make the same changes here that you made previously. Then type:

sudo update-grub
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.