Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've installed win 7 and ubuntu 11.04. I was trying to upgrade my machine to 11.10.

It was all good, it installed all the upgrades and asked me to restart.

After restarting I got the login screen only once. After that there was just a blank screen. So I manually restarted it.

Now whenever I tried to restart, I get the

Busybox v1.18.4 (Ubuntu 1:1.18.4-2ubuntu2) built-in shell(ash)
Enter help for a list of built-in commands. 

(initramfs)

Here's what happens when i boot:

  • Bios loads
  • Grub displays option to load:

    ubuntu with Linux 3.0.0-19-generic
    ubuntu with Linux 3.0.0-19-generic (recovery mode)
    Previous versions Linux
    memtest
    another memtest option
    win7 (loader) (on /dev/sda2)
    

I am able to log in to the Windows 7 though.

If I log on to the previous linux versions also I am ending up at the same error.

Things I have tried:

  1. When I type exec startx it gives the following error:

    /bin/sh : exec: line 0: startx: not found
    
    [ 123.764413] kernel panic - not syncing : Attempted to kill init!
    [ 123.764441] Pid : 1, comm : init not tainted 3.0.0-19 generic #33-Ubuntu
    [ 123.764466] call Trace :
    

    and a bunch of commands

    The caps Lock but is blinking right now at this stage. I need to manually shut it down.

  2. Tried to log in to the recovery mode

    It gives the error : a bunch of errors (Please let me know if I need to list them. ) Then the last error is No init found. Try passing init=bootarg.

Then I am stuck at the busybox error and the busybox initramfs prompt.

  1. Tried to log in to the Previous Linux versions, but get the same busybox initramfs prompt.

sudo fdisk -l
Disk /dev/sda: 750.2 GB, 750156374016 bytes
255 heads, 63 sectors/track, 91201 cylinders, total 1465149168 sectors

Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0xf5cd5cce
   Device Boot      Start         End      Blocks   Id  System
/dev/sda1            2048      206847      102400   de  Dell Utility
/dev/sda2   *      206848    30926847    15360000    7  HPFS/NTFS/exFAT
/dev/sda3        30926848   953147119   461110136    7  HPFS/NTFS/exFAT
/dev/sda4       953149438  1465145343   255997953    f  W95 Ext'd (LBA)
Partition 4 does not start on physical sector boundary.
/dev/sda5       953149440  1239869439   143360000    7  HPFS/NTFS/exFAT
/dev/sda6      1362751488  1465145343    51196928    7  HPFS/NTFS/exFAT
/dev/sda7      1239871488  1346158591    53143552   83  Linux
/dev/sda8      1346160640  1362745343     8292352   82  Linux swap / Solaris
Partition table entries are not in disk order

sudo sfdisk -uS -l /dev/sda
Disk /dev/sda: 91201 cylinders, 255 heads, 63 sectors/track
Warning: extended partition does not start at a cylinder boundary.
DOS and Linux will interpret the contents differently.
Units = sectors of 512 bytes, counting from 0
   Device Boot    Start       End   #sectors  Id  System
/dev/sda1          2048    206847     204800  de  Dell Utility
/dev/sda2   *    206848  30926847   30720000   7  HPFS/NTFS/exFAT
/dev/sda3      30926848 953147119  922220272   7  HPFS/NTFS/exFAT
/dev/sda4     953149438 1465145343  511995906   f  W95 Ext'd (LBA)
/dev/sda5     953149440 1239869439  286720000   7  HPFS/NTFS/exFAT
/dev/sda6     1362751488 1465145343  102393856   7  HPFS/NTFS/exFAT
/dev/sda7     1239871488 1346158591  106287104  83  Linux
/dev/sda8     1346160640 1362745343   16584704  82  Linux swap / Solaris
share|improve this question
    
Can you post your /etc/fstab on pastebin.ubuntu.com and give us a link to your paste? –  hexafraction Jun 4 '12 at 11:46

2 Answers 2

up vote 0 down vote accepted

For me this happens every boot, as my RAID system has a failure.

If you press Ctrl-D the boot goes on.

If you successfully booted the system, try to check you raid status (mdadm --misc --detail --/dev/mdXXX) and filesystem consistency (fsck /dev/sdaX and bX)

share|improve this answer
    
When I type Ctrl-D, I get the following error. /init : line 352 : cant open /root/dev/console : no such file. –  user1046649 May 16 '12 at 14:53
    
that looks like, your root is shifted. It should not try with /root/dev/console.. it should try /dev/console. Can you look in to the system with bootCD? like systemrescuecd? –  user61664 May 16 '12 at 14:57
    
I have to restart it again!! Thanks for your help. Can you please let me know what might be the problem and how to solve it. –  user1046649 May 16 '12 at 14:58
    
I dont have a boot cd. How do I make one? Can you give me the details. Thanks. Your help is really appreciated. –  user1046649 May 16 '12 at 14:59
    
I have a USB stick. Can I use it somehow. If so , can you give me the details. –  user1046649 May 16 '12 at 15:01

I found the answer with this website, thanks to Wyatt Smith and David S.

https://answers.launchpad.net/ubuntu/+source/linux/+question/195941

Basically, so create a liveUSB, boot up using this. There's loads of info online for how to do this in official Ubuntu documentation.

Boot up with the USB plugged in. In the Bios screen select boot options (or the other options, can't quite remember) select the USB select try ubuntu wait run "gparted" (this is used to adjust and fix any problems with partitions) one by one select each partition, right click, select "check" Then click the green tick to execute the operation this will check and fix your partitions. It is highly unlikely your hard drive is broke, it's probably that you didn't properly shut down and something got messed up. when you've done each partition (some are not possible) then restart normally and select your normal ubuntu.

This should fix your stuff.

This is not my fix, but I found it worked for me, so good luck. I've seen this problem on a few sites, so I'm repeating the post.

Alex

share|improve this answer

protected by Community Oct 19 at 6:55

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.