Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I use Ubuntu 11.04 fully updated, classic Gnome DE, Synaptic for installations and uninstallations.

I have uninstalled Banshee, Empathy and Evolution which are I am not going use ever. Did mark for complete removal and also selected some other items like empathy-common, evolution-common, etc..

Everything was fine until I rebooted it. Both top and bottom panels are not showing. I am also using AWN (Avant Window Navigator), so for now I am using it's panels.

I think I have uninstalled something which need to load those top and bottom panels.

Please help me to bring them back. :)

share|improve this question
use killall gnome-panel and then gnome-panel from run dialog and see if it launches then. – Kushal May 16 '12 at 13:29
Thank you @Kush . Your comment solved it. Check my answer. :) – user45315 May 17 '12 at 2:42

Gnome is independent of other programs installed in your system. So it has nothing to do with their removal. Try removing and reloading gnome-shell.

share|improve this answer
yes @aarti, gnome is independent. Don't know more about this but gnome-panel is dependent on some other packages which I have mentioned in my answer. :) – user45315 May 17 '12 at 3:24

If you want to have back all the original ubuntu packets, you can try: sudo aptitude install ubuntu-desktop. Quoting from here:

ubuntu-desktop: In addition to ubuntu-base, this package depends on all of the packages in the Ubuntu desktop system. It installs a desktop environment (GNOME) and lots of software for home and office use.

That's surely the fastest way to restore ubuntu to its initial packet state.

share|improve this answer
thanx for the help, but just installing gnome-panel has solved my problem. :) – user45315 May 17 '12 at 3:25
up vote 0 down vote accepted

Kush's comment helped me for this.

  1. First run gnome-panel in terminal.
  2. If gnome-panel is not installed, install it using sudo apt-get install gnome-panel
  3. And try gnome-panel again. It will show up.

In my case during installation I noticed that it is also installing evolution-data-server, gnome-applet, indicator-applet-appmenu, indicator-applet-complete and libedataserverui. From which, last day I had uninstalled evolution-data-server myself.

Here is the full log, just in case:

ikrz@ikrz-Lenovo-G570:~$ gnome-panel
The program 'gnome-panel' is currently not installed.  You can install it by typing:
sudo apt-get install gnome-panel
ikrz@ikrz-Lenovo-G570:~$ sudo apt-get install gnome-panel
[sudo] password for ikrz: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  linux-headers-2.6.38-8-generic linux-headers-2.6.38-8
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  evolution-data-server gnome-applets indicator-applet-appmenu
  indicator-applet-complete libedataserverui1.2-11
Suggested packages:
  evolution evolution-data-server-dbg gnome-netstatus-applet deskbar-applet
  cpufrequtils epiphany-browser menu-xdg
The following NEW packages will be installed:
  evolution-data-server gnome-applets gnome-panel indicator-applet-appmenu
  indicator-applet-complete libedataserverui1.2-11
0 upgraded, 6 newly installed, 0 to remove and 0 not upgraded.
Need to get 943 kB/1,386 kB of archives.
After this operation, 4,444 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 natty/main libedataserverui1.2-11 amd64 2.32.2-0ubuntu2 [101 kB]
Get:2 natty/main gnome-applets amd64 [179 kB]
Get:3 natty/main evolution-data-server amd64 2.32.2-0ubuntu2 [615 kB]
Get:4 natty/main indicator-applet-appmenu amd64 0.4.12-0ubuntu1 [23.4 kB]
Get:5 natty/main indicator-applet-complete amd64 0.4.12-0ubuntu1 [24.4 kB]
Fetched 943 kB in 7s (134 kB/s)                                                
Selecting previously deselected package libedataserverui1.2-11.
(Reading database ... 241087 files and directories currently installed.)
Unpacking libedataserverui1.2-11 (from .../libedataserverui1.2-11_2.32.2-0ubuntu2_amd64.deb) ...
Selecting previously deselected package gnome-panel.
Unpacking gnome-panel (from .../gnome-panel_1%3a2.32.1-0ubuntu6.5_amd64.deb) ...
Selecting previously deselected package gnome-applets.
Unpacking gnome-applets (from .../gnome-applets_2.32.1.1-0ubuntu5_amd64.deb) ...
Selecting previously deselected package evolution-data-server.
Unpacking evolution-data-server (from .../evolution-data-server_2.32.2-0ubuntu2_amd64.deb) ...
Selecting previously deselected package indicator-applet-appmenu.
Unpacking indicator-applet-appmenu (from .../indicator-applet-appmenu_0.4.12-0ubuntu1_amd64.deb) ...
Selecting previously deselected package indicator-applet-complete.
Unpacking indicator-applet-complete (from .../indicator-applet-complete_0.4.12-0ubuntu1_amd64.deb) ...
Processing triggers for man-db ...
Processing triggers for gconf2 ...
Setting up libedataserverui1.2-11 (2.32.2-0ubuntu2) ...
Setting up gnome-panel (1:2.32.1-0ubuntu6.5) ...
Setting up gnome-applets ( ...
Setting up evolution-data-server (2.32.2-0ubuntu2) ...
Setting up indicator-applet-appmenu (0.4.12-0ubuntu1) ...
Setting up indicator-applet-complete (0.4.12-0ubuntu1) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
ikrz@ikrz-Lenovo-G570:~$ gnome-panel

Thanks to all others who tried to help me. I appreciate it. :)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.