Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have win7 64 bit and wish to install ubuntu 12.04 via wubi. Seemingly I am unable to run wubi installer.

  1. Made wubi installer as vista compatible.
  2. Put the iso & wubi in the same folder.
  3. Tried using the --force method.

In the log file it says to look for kubuntu alternate cd & cannot find it

Maybe python variable are active or how could i delete them.

Any help - much appreciated

share|improve this question
    
Post the log file or pastebin it so we can see. –  bcbc May 17 '12 at 17:09
add comment

3 Answers

The latest version of wubi is compatible with windows 7. So no need to change the comparability.

  • Get latest wubi here (For installation of 12.04).
  • Download correct version of ubuntu.

More info: https://wiki.ubuntu.com/WubiGuide

ubuntu download links → http://www.ubuntu.com/download/desktop

share|improve this answer
    
I HAVE DOWNLOADED THE CORRECT VERSION - EVEN DONE MD5 HASH ALSO. BUT EVEN THEN IT DOES NOT START AT ALL I HAVE HAD LINUXMINT MINT4WIN INSTALLER FOR MINT 12 - IT WORKED PROPERLY. BUT NOT THIS WUBI. –  ASSAD May 16 '12 at 10:30
    
can you please turn off CAPS LOCK ? Note that you need a DESKTOP CD ISO. A DVD ISO may not work. Alternate ISO files are not supported. Which file have you downloaded? 32bit version or 64bit version? –  Web-E May 16 '12 at 10:37
    
its 32 & 64 bit desktop iso. got wubi as well. as i told you in the log file in temps directory it seems to look for kubuntu alternate 64 bit cd iso. –  ASSAD May 16 '12 at 11:32
add comment

I recently faced a similar problem but I figured out what's wrong

What I did was checked the temp dir(run>temp) and checked the logs file with notepad. (and recently found that WUBI checks iso file(any) in your hard disk)

In my case there was a iso file in my drive (E:/matrix_path_of_neo.iso) and WUBI tried to consider it as an Ubuntu iso.(I don't now if its a kind of bug)

I simply just renamed the file format of the file which was in E drive (.iso to .iso1) and this solves my problem as WUBI does not recognised it as a iso file.

So if you try to check the log file and read out the errors and try to solve it as I mentioned above this will work 100% of the time from my experience.

share|improve this answer
add comment

finaly solved the issue

1) cleared all temps directory & process locked files 2) disconnected internet 3) made sure that no wubi or ubuntu iso are on the HD. 4) mounted the ISO and used the --force method

and it worked.

Finally!!

A friend of mine also said to me wubi works on XP with disconnected internet.. Is this a bug

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.