Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a bluetooth headset that has been working fine for about a year. Recently it has been failing, and I believe the time it has been problematic coincides with upgrading to 12.04.

The device pairs just fine. However, every time I try to connect, I get an error that says "Connection failed: Connect failed".

bluetooth fail

I ran blueman-manager from the command line, and got this output (edited down to just the tail end when the connection failed):

Generate (/usr/lib/python2.7/dist-packages/blueman/gui/manager/
unset_op (/usr/lib/python2.7/dist-packages/blueman/gui/manager/
op: regenerating instance <ManagerDeviceMenu object at 0x2d16b90 (GtkMenu at 0x2e5b750)> 
fail (/usr/lib/python2.7/dist-packages/blueman/gui/manager/
fail (DBusException(dbus.String(u'Connect failed'),),) 

Also, based on suggestions, I tried disabling SSP with the following command: sudo hciconfig hci0 sspmode 0, but it does not seem to have helped.

Lastly, I have tried unpairing and repairing, and sometimes that gets me some connectivity, but not always, and in any case it's a hassle to have to repair every single time.

What do I need to do to fix this error and restore my bluetooth device to its former level of reliability?

share|improve this question

closed as off-topic by James Dec 16 '13 at 14:53

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – James
If this question can be reworded to fit the rules in the help center, please edit the question.

Closed as non-reproduceable, but this is the exact problem I've always had too. – Luke H Jun 11 at 10:08

My workaround for this issue is to remove the headset from the list of known devices (from Bluetooth setup) and repeat the pairing.

The headset will then continue to work as expected until it was connected to another machine (which could also be a virtual machine on the same computer). Then we again have to remove the device and repeat the pairing.

There may be an issue with secure sinmple pairing that occured from 11.10 but is supposed to be fixed in kernel 3.2.15 (see bug #931860). Try if disabling SSP resolves your issue too.

share|improve this answer

I hope this is not too late or out of topic.

I have namely 12.10 and had the same problem. I solved it opening "Local Services" in Blueman and selecting "Advanced Audio Receiver" and "Headset Emulation" under the Audio tag in the window that pops up.

I accepted the fact that these services are "Experimental" and "Very Experimental". It worked for me.

share|improve this answer

The thread is quite old, but maybe it helps someone:

Try this, add:

Disable = Media

into "General" section of /etc/bluetooth/audio.conf

On many forums they recommend adding "Enable = Socket" as well, but in my case it made no difference; but "Disable = Media" is different coffee, with this all my bluetooth headsets connect again like a charm.

Anyway, I noticed my bluetooth headset won't connect to my laptop anymore after I moved from Ubuntu 10.04 to 12.04 (and subsequently to Mint 13 Maya).

Strangely the headsets were connected immediately after pairing, but could never connect afterwards...

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.