Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I created a vpn by using

$ nslookup vpn.ipredator.se

to find the ipredator ip address to use (eg 93.182.174.130) - I didn' t use "vpn.ipredator.se" as the Gateway in the Network Manager applet, because that didn't work on 10.04.

The VPN works fine, but when I try to bind deluge to the VPN ip address (via Edit -> Preferences -> Network -> Interface) I get this tracker error:

"openbittorrent.com: Error: Cannot assign requested address", and there are no connections. Other applications still work over the VPN.

When I remove the ip address from the Interface box and click Apply, deluge works fine.

I am using 12.04 64 bit (Classic) and I had the same problem with 10.04

Deluge 1.3.5

I'm only after a way to stop my ip address leaking when the VPN cuts out. This seems like the simplest method (if it would work), but I'm open to other methods. I'm not comfortable with ip tables, but from what I can gather I can assign a range of ports for deluge to use, and then use GUFW to only allow traffic on those ports to the ipredator server.

I guess this is a deluge bug, or a quirk of how trackers work. Anyone else had the same issues? Any ideas for troubleshooting?

share|improve this question
add comment

1 Answer 1

If your vpn connects to 93.182.168.2

The Deluge interface must be 93.182.168.2*

edit: This doesn't work.

Neither does setting both the VPN Gateway and deluge interface to vpn.ipredator.se - deluge still runs when the vpn disconnects, but only connects to peers who are also using ipredator.

There seems to be no easy way to do this (could be done by using iptables or editing routes in /etc/ppp).

Switched to qbittorrent instead. Advanced tab in options lets you set the network interface to ppp0. Seems to work.

share|improve this answer
    
what version of libtorrent are you using with Deluge? –  Cas Jun 15 '12 at 2:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.