Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have just installed the latest version of Ubuntu and I want to connect to the Internet using my wireless router.

I tried using Ndiswrapper but I received errors. I also tried using suggestions in this WiFiHowTo.

When I try installing from the additional drivers, I receive the error messages below.

Sorry, installation of this driver failed.
Please have a look at the log file for details: /var/log/jockey.log

2012-05-15 19:14:29,861 DEBUG: Instantiated Handler subclass __builtin__.BroadcomWLHandler from name BroadcomWLHandler
2012-05-15 19:14:29,862 DEBUG: Broadcom STA wireless driver availability undetermined, adding to pool
2012-05-15 19:14:29,862 DEBUG: loading custom handler /usr/share/jockey/handlers/
2012-05-15 19:14:29,873 WARNING: modinfo for module ath_pci failed: ERROR: modinfo: could not find module ath_pci
share|improve this question

closed as too localized by Ringtail, qbi, Eric Carvalho, Chris Wilson, Mik Jan 14 '13 at 23:29

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Can you post the output of lspci so i can see exactly what Broadcom card you have? – Octávio Filipe Gonçalves May 15 '12 at 23:52
The content of the log file /var/log/jockey.log might also be helpful. – irrational John May 16 '12 at 3:29

I experienced the same problem this weekend on a buddy's laptop. He has a Broadcom 4312.

I partially used this answer to another AskUbuntu question. The only difference is that once I removed:


I installed


and then rebooted.

The Network Manager showed the wireless card was installed, but displayed a message that the hardware switch was disabled.

Regardless of what I tried to enable (by clicking function and the wifi key) this would not change. I then decided to re-open the additional drivers and was able to activate the driver successfully. Once I restarted the machine, the wireless worked fine.

share|improve this answer

I have Broadcom BCM4312 and using ndisgtk(ndiswrapper) worked perfectly. use windows driver for your wifi chipset (usually drivername.inf). reboot and most cases it worked. You can give it a try.


share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.