Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've Dell Inspiron N5110 with 8 GB of RAM, I installed Ubuntu 12.04 64-Bit.

The problem is that all things are working fine but Ubuntu detects only 7.7 GB of RAM, I've checked & noticed that I've 4 GB of Kingston & 4 GB of Samsung RAM.

Now I've installed Windows to check if it is RAM fault or what, Windows 7 is showing 8 GB of RAM.

Dedicated graphics yes Video card NVIDIA GeForce GT 525M (DirectX11, SM 5.0, PureVideoHD) Video card memory 1 024 MB

http://ark.intel.com/products/53469

Intel® Core™ i7-2670QM Processor (6M Cache, up to 3.10 GHz)

Processor Graphics Intel® HD Graphics 3000

Updated

there is no option in bios to set graphic card ram or to set which graphic card to use ... i have checked 7 to 8 time ...

share|improve this question
    
Check /var/log/kern.log or dmesg and look for the section listing the bios e820 map and add that to your question. –  psusi May 16 '12 at 1:06

2 Answers 2

up vote 5 down vote accepted

so the problem is that all things are working fine but Ubuntu detects only 7.7 GB of ram

Your laptop (Dell N5110) uses Intel integrated graphics (HD Graphics 2000), and this uses some amount of your RAM as "Graphics Memory". Compare to a dedicated graphics/video card which has its own onboard RAM. Even if your laptop has a dedicated ATI/NVidia card, the laptop is usually set by default to automatically "switch" between the two (Nvidia calls this Optimus), and that means that the integrated Intel graphics will reserve memory even if you aren't using them.

Windows includes the reserved video RAM in its count, while Ubuntu doesn't. You can't use this reserved RAM in either OS, in any case.

Your BIOS should let you set a specific value for the amount to be reserved, instead of automatic -- I recommend you pick at least 128MB. Then Ubuntu will show the remainder (8064 MB) as available and usable. Alternately, if you wish to only use the discrete (Nvidia/ATI) card, you can also select that as an option in the BIOS, disabling Intel graphics completely, which should give you access to all of your RAM (warning: this may decrease battery life).

share|improve this answer
    
i have 1 gb of nvidia integrated graphic card –  One Zero May 15 '12 at 22:54
    
You need to disable Optimus (switching) then, and set your BIOS to use only "discrete" (i.e., Nvidia only). –  izx May 15 '12 at 22:57
    
let me chk in bios & let you know –  One Zero May 15 '12 at 23:01
    
i have checked in the bios there is no option for graphic ... –  One Zero May 15 '12 at 23:08
    
How about share memory, vram, or something along those lines? It is probably under advanced settings somewhere... –  hexafraction May 15 '12 at 23:25

It no problem after all you are having 7.7GB Ram .. Their should not Be any performance issue.Your ram is shared with integrated graphics memory of your Processor, So don't take it seriously your PC is Fine.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.