Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu 12.04 on my HP laptop and cannot enable my wireless card. I have checked the BIOS and it is enabled there. I have checked the drivers and I think I have the correct one. The option to enable wireless is grayed out. I am a new Ubuntu user so any help would be appreciated.

My laptop has an Intel/PRO 3945 wireless card installed.

Here is a printout of lspci -vv:

10:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
    Subsystem: Hewlett-Packard Company Device 135b
    Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0, Cache Line Size: 64 bytes
    Interrupt: pin A routed to IRQ 46
    Region 0: Memory at e4100000 (32-bit, non-prefetchable) [size=4K]
    Capabilities: <access denied>
    Kernel driver in use: iwl3945
    Kernel modules: iwl3945

Please let me know if any other information would help.

share|improve this question
    
does it show in the grayed wireless line that it is "disabled by hardware switch" or something like that? - in which case type in terminal sudo rfkill unblock wifi. Just type it anyway to see. –  cipricus Aug 5 '12 at 16:53

2 Answers 2

Try connecting to your router or modem with an ethernet cable and then check the Additional Drivers program (open up Launcher and search for "driver" and it should come up). I have a laptop with an Intel wireless card and I had to install the driver from Additional Drivers.

share|improve this answer

Just to be sure, have you checked the physical Wifi on/off switch on the laptop?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.