Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My volume keys are not working in xfce. When I used them it shows an indication on the screen that the volume is being changed, but the volume is not changing at all (same thing with the mute key).

The weird thing is that when I go from xfce to ubuntu the keys are now working fine.

I don't know if this matters but I have a sound card in my computer.

How can I make the volume keys work in xfce?

share|improve this question
    
Do you have other sound devices activated such as HDMI? Perhaps the volume keys are configured to these devices rather than your primary speaker. Try go to the volume control (or type pavucontrol in terminal) and look under configuration for other devices. Turn any other devices off than your built-in audio and log out to see the changes. –  Christian Skjødt May 15 '12 at 17:56

5 Answers 5

up vote 9 down vote accepted

This is still broken in 12.10. You can fix it by installing xfce4-mixer and then manually selecting the mixers to control with it - and then going into the xfce4 settings editor and typing in the name of the "active card". The mute button still won't work properly, you can mute but not unmute the sound with it. Everything else works though, including on screen notifications. It's really tricky to get it all working, so I opened a bug: https://bugs.launchpad.net/ubuntu/+source/xfce4-mixer/+bug/1085752

In detail, in xfce4-mixer you want it to look something like this:

xfce4-mixer

This should show only the primary volume control of your sound card. You have to choose a sound card at the top and then click "Select Controls..." to add controls. Then in the xfce4-settings-editor you need to set the "active-card" like this:

xfce4-settings-editor

Under "sound-cards" you'll see a list of every sound card for which you added mixers. You will probably have multiple cards so it might take some trial and error here to find the right one. You need to copy the name of the correct card from "sound-cards" to "active-card" - this will be the mixer which the volume buttons control.

share|improve this answer
    
I managed to find a card that I could control with volume up, volume down, and mute - but not unmute. I had to instead use a different card for unmute to work; I was able to figure out which card to use by finding the one all of the controls worked in the xfce4-mixer app (and not having to go through the entire process of adding the card and testing my keyboard shortcuts every time). –  corvec Apr 2 '13 at 14:44
    
For some reason "active-card" is not listed under "Property" for me. –  user87317 Feb 14 at 18:08
    
@user87317 I have the same problem, you need to copy it from 'sound-card' property value. it is a simple string. –  logoff Mar 15 at 15:29

Those volume keys are gnome based... Or unity based or whatever... You have to create a custom keyboard shortcuts in the keyboard settings gui to reduce, increase and mute volume... For volume increase, the command is "amixer set master 5%+" for volume decrease "amixer set master 5%-" for mute "amixer set master toggle"

share|improve this answer
    
This works, but it doesnt provide the notify-osd which comes with xfce4-volumed.. so there's no on screen feedback at all... –  kolslorr Nov 6 '12 at 7:45

I had the same problem in Xubuntu 12.04, though I don't know if it would have worked in Unity, since I only have Xfce4. In terminal, type:

$ xfconf-query -c xfce4-mixer -p /active-card -s xfconf-query -c xfce4-mixer -p /sound-card

Source: https://wiki.archlinux.org/index.php/Xfce#Xfce4-volumed

share|improve this answer
    
This won't work in 12.10 because xfce4-mixer isn't installed by default and so those settings won't exist. See my answer below for how to create them. –  Alistair Buxton Dec 3 '12 at 0:37

xfce4-volumed only works for me when it is not running in daemon mode. The volume keys work for me when I run this command to kill any existing volumed processes and start a new one that is not running in daemon mode:

kill `pidof xfce4-volumed` ; mkdir -p /tmp/volumed && cd /tmp/volumed && nohup xfce4-volumed --no-daemon &

This runs the process using nohup, so the terminal in which you run this command can be closed without killing the process.

share|improve this answer

I fixed the problem changing the "Active Card" parameter in the xfce4-settings-editor

I have two sound card (one HDMI and the other a normal one) and the selected card was different from the normal card that I was using.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.