Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm RDP-ing to a WIN2K8 machine from Ubuntu 12.04+Remmina but EVERY TIME I'm prompted with a Certificate Validation.

Does anybody knows how to avoid these messages or validate them for good?

.

share|improve this question

2 Answers 2

Does anybody knows how to avoid these messages

enter image description here

  • Right-click to edit the connection
  • Under the "Advanced" tab, set security to either:
    • RDP (less secure, good for local networks)
    • TLS (more secure, better for remote/WAN connections)

Neither of these options will prompt you ever :)

share|improve this answer

enter image description here

You get this message because the hostname of the certificate does not match the hostname configured in the connection profile in Remmina. To avoid the certificate validation message you can put the fingerprint of the server-certificate in ~/.freerdp/known_hosts.

Example: hostname zb:45:r9:cu8:34:28:z8:69:45:32:19:02:zc:31:4f:b4:p5:34:76

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.