Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Not an error, per se, more of an observation. Since upgrading to 12.04, I have found and solved some interesting problems. Given my complete lack of Ubuntu knowledge, this has indeed made me feel more than a little cocky. However, the one (!) thing I cannot figure out is the whole Dual Monitor setup.

Anyway, the blah bit... Fujitsu Siemens Amilo 3530, ATI Radeon 3200 HD Series, 4GB RAM 1TB HDD and so on, generic HDMI monitor. Got the GNOME fglrx loaded with the kosher latest ATI driver (but not the post update one, that one just will not activate)

Now, in 11.10, it just wouldn't work, at all, not even when tempted with tasty treats and promises of great pleasure. Still, I persisted and, when I noticed the 2nd Monitor working with the 12.04 Try Out DVD, I went for it.

After getting 12.04 running, the HDMI still shows nothing but blue screen on the telly, telling me 'No Signal". On VGA, if I attempt to set it as a second monitor, I get two errors:

The selected configuration could not be applied

required virtual size does not fit available size: requested=(2880, 900), minimum=(320, 200), maximum=(1600, 1600)

Then, click Close and you get the following:

GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._gnome_2drr_2derror_2dquark.Code3: required virtual size does not fit available size: requested=(2880, 900), minimum=(320, 200), maximum=(1600, 1600)

But, if I mirror the display, it works on the monitor, no problem.

So, the fact that it is not working IS NOT MY FAULT!

Any one get any suggestions?

Ta.

Mark

share|improve this question
    
I'm getting very similar problems. I had 12.04 running fine on my office computer yesterday, including dual monitors unmirrored, but today I deleted the old install and installed direct from the install CD. Dual monitors were working fine, then I tried to use the proprietary ATI drivers and it hasn't been working properly since. When I installed the ATI driver, it won't allow a rotation to the monitor when not mirrored. Weird. But then I clone the displays and rotation is fine. I get a very similar GDBus error. The problems persist if I uninstall the ATI driver. Gah! –  Ryan Budney May 23 '12 at 6:13
    
Installing then uninstalling the ATI drivers seems to have brought my dual displays back to functioning normalcy. –  Ryan Budney May 23 '12 at 6:27
    
@Ryan : How do I uninstall the ATI drivers? –  user35559 May 24 '12 at 3:13
    
@user35559: go to "additional drivers" under "system settings" and there are options to install and uninstall ATI drivers, provided you have ATI hardware. –  Ryan Budney May 24 '12 at 6:15
    
I have to say this post made me chuckle on a few different levels... –  TheX Sep 28 '12 at 18:20

9 Answers 9

This is my first post, so let me know if I do something wrong.


It took about an hour, but I ended up getting it to work.

This assumes that you have the propriety driver.

Step 1: Set the resolution correctly of your first monitor using the AMD Catalyst Control Center.

Note: Although it may seem like everything can be solved using this, it can't.

Step 2: Restart your computer.

Step 3: Go to System Settings > Display and activate your second monitor.

Note: Even though it will be detected in the AMD Catalyst Control Center, the only settings that stick are the resolution settings.

Step 4: Restart your computer.

Step 5: Go to the AMD Catalyst Control Center and make sure the display is set up correctly.

For example, I changed it to Multi-display desktop(s) with 2 displays.

Step 6: Restart your computer.

Step 7: Go to System Settings > Display and set the resolution of your second monitor.

Note: I also disabled Sticky edges.

Step 8: Restart your computer.

All of the display settings should now be saved correctly.


Incidentally, I have no idea why all of this works. It just does.

share|improve this answer

Try change virtual size in your xorg.conf.

Go to:

gksu gedit /etc/X11/xorg.conf

Find Section "Screen" and there should be SubSection "Display" and there you should paste your virtual size....

Mine looks like this:

Section "Screen"

    Identifier "aticonfig-Screen[0]-0"
    Device     "aticonfig-Device[0]-0"
    Monitor    "aticonfig-Monitor[0]-0"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth     24
        Virtual         3400 1200
    EndSubSection
EndSection

Save it and than run in terminal:

sudo aticonfig --input=/etc/X11/xorg.conf --tls=1

I had the same problem but set up virtual size (more than is my resolution = monitor + notebook (1920 + 1366 = 3286 = I set up 3400 and 1200) solve this problem :). Hope it will help.

share|improve this answer
    
Excellent. Did this and now both displays run at maximum (but different) resolution. –  AntonyW Oct 26 '12 at 18:38
1  
For me, this worked only after I restarted X server. (Before the restart there was still annoying message with resolution limit) –  Michal Kováč Feb 2 '13 at 12:11

Seems like there is some sort of limit on the maximum size, when combining the two displays. 1600x1600. When you stack your two monitors side by side, they exceed this limit. I tried putting one below other and it worked. Its not the ideal config for me but it works.

Please try and let me know how you like it.

share|improve this answer
    
I've been told (https://bugs.freedesktop.org/show_bug.cgi?id=81476) that "the rendering is done on one GPU", so that one GPU has to handle the combined sizes of the two displays when not mirrored. The GPU limit is what that maximum=(1600, 1600) means, and that is why two 1440x900 monitors won't work (because 1440+1440=2800 which is more than 1600). If you run the monitors as mirrors or as separate displays, that would fit within the GPU 1600 limit. You can also use the Xinerama X11 option to get around the limitation, but that disables all the nice 3D RandR stuff. –  IDAllen Jul 19 at 7:42

Catalyst tools are your best bet.

I have an Intel gfx adapter on my laptop and routinely connect to an external monitor. I am using KDE4.9 on kubuntu 12.04 desktop. When an external monitor is (dis)connected, KDE Daemon brings up a "Monitor has changed" dialog, from where I can configure the monitors.

I also use xrandr to configure from command line.

$ xrandr
Screen 0: minimum 320 x 200, current 1366 x 768, maximum 8192 x 8192
LVDS1 connected 1366x768+0+0 (normal left inverted right x axis y axis) 344mm x 193mm
   1366x768       60.0*+
   1360x768       59.8     60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 connected (normal left inverted right x axis y axis)
   1280x1024      60.0 +   75.0  
   1152x864       75.0  
   1024x768       75.1     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        72.8     75.0     66.7     60.0  
   720x400        70.1  
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)

I use a scripts such as:

xrandr -q
xrandr  --output VGA1 --auto
xrandr  --output LVDS1 --primary
xrandr  --output VGA1 --left-of LVDS1
xrandr  --output LVDS1 --primary

and later,

# we can also turn off the LCD panel
xrandr --output VGA1 --off

Hope that helps.

share|improve this answer

For me adding "virtual 3400 1900" worked: basically just edit /etc/X11/xorg.conf file using

sudo nano /etc/X11/xorg.conf

to save, request close: Ctrl+X, save Y, quit: Enter. Note Virtual **** **** depends upon your external display. Just add max resolution ratio.

In my /etc/X11/xorg.conf I now get:

Identifier "aticonfig-Screen[0]-0"
    Device     "aticonfig-Device[0]-0"
    Monitor    "aticonfig-Monitor[0]-0"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth     24
        Virtual         3400 1900
share|improve this answer

Not sure if you've done this or not but you HAVE to use the catalyst control centre to set them up. I'm going through setting mine up now, which is how I came across this. Finally got mine going but it has a launcher on each screen and is buggy when moving the mouse across monitors. I'm trying to find answers for those problems :/ Pretty much AMD + Ubuntu + dual monitors = pain in the proverbial. If you have been using catalyst to set them up i'm lost as to why it won't work. I've always been able to get something going since natty.

share|improve this answer
1  
Catalyst Control Centre really is a piece of bugged to hell crap. Last time I tired it, it just didn't even notice that a second monitor was plugged in. I have to say that I am deeply disappointed in Ubuntu and ATI regarding this matter. Jesus, it's not as though ATI is a small player. How bloody difficult can it be for these people to release software and hardware that actually works. And. I don't accept that 'we can't try it on every platform' garbage. I don't think that a Fujitsu Siemens Amilo 3530 is anything special. AMD, ATI, Ubuntu, come on. Really, it should just work. –  Mark L. Potts May 20 '12 at 12:49

ATI RV630 [Radeon HD 2600XT] All I can suggest is running it without loading a driver if that's possible for you.

I set mine up in 2/3 minutes using the cogwheel/display and it was fine. I have programs written under allegro that were snail slow without a driver, sometimes pausing for 2 seconds on the display. In the past the only thing I found that worked for loading drivers was envyNG but too old now? This didn't work for me, http://www.ubuntugeek.com/how-to-install-ati-radeon-hd-2600-drivers-in-ubuntu.html but succeeded in destroying the dual monitor setup and giving the "required virtual size does not fit available size: requested=(2560, 1024), minimum=(320, 200), maximum=(1600, 1600)" error. So system unusable and now stuck ( and so many other things to sort out as well ).

share|improve this answer

I have an ATI Mobility Radeon HD 5650, and I had the same problem. It worked originally, but when I installed the custom drivers, it stopped working. I just went back to using the drivers that came with Ubuntu, and it worked again.

share|improve this answer

I had the same problem with a Asus laptop with a ATI Radeon HD 3470 card. Using system setings-display didn't cut it. But running AMD Catalyst Control Center (Administrative) from the dash an seting up everything corectly there, did the job, after a restart. Hope it hels you.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.