Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've recently updated (well, borked then completely reinstalled) to 12.04.

I'm running a dual monitor setup, with a Dell U2410 / Dell 2007WFP combination on an HP Elite Book 8560W. The graphics card is an NVIDIA GF108 [Quadro 1000M].

My problem is as follows. I can get the dual monitor setup working fine, but every time I reboot, my machine appears to lose the settings (specifically, the U2410 is disabled, the mouse pointer is locked in the launcher). I have to restate the settings after every launch. I've tried running nvidia-settings as sudo, I've save the changes to my xorg.conf file (see below) but nothing seems to be sticking.

Has anyone had similair issues, or know of a fix? Conf file follows:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 295.33  (buildd@allspice)  Fri Mar 30 15:25:24 UTC 2012

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "DELL 2007WFP"
    HorizSync       30.0 - 83.0
    VertRefresh     56.0 - 76.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "Quadro 1000M"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "1"
    Option         "TwinViewXineramaInfoOrder" "DFP-1"
    Option         "metamodes" "CRT: 1680x1050 +1920+0, DFP-1: 1920x1200 +0+0; CRT: nvidia-auto-select +0+0, DFP-1: NULL"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

The error message I'm getting is this:

none of the selected modes were compatible with the possible modes: 
Trying modes for CRTC 642:
CRTC 642: trying mode 3600x1080@50hz with output at 1280 x 1024@0Hz (pass 0)
CRTC 642: trying mode 3600x1080@50hz with output at 1280 x 1024@0Hz (pass 0)
CRTC 642: trying mode 3600x1080@50hz with output at 1280 x 1024@0Hz (pass 0)
CRTC 642: trying mode 3600x1080@50hz with output at 1280 x 1024@0Hz (pass 1)
CRTC 642: trying mode 3600x1080@50hz with output at 1280 x 1024@0Hz (pass 1)
CRTC 642: trying mode 3600x1080@50hz with output at 1280 x 1024@0Hz (pass 1)
share|improve this question
add comment

3 Answers

up vote 7 down vote accepted

Remove all files Xorg.conf (or/and Xorg.conf.new) You can find (search in /etc/X11 /usr and in Your Home directory). Then run:

sudo nvidia-settings

and set options as You wish. Reboot. Did it help?

If that didn't help try to create Xorg file and manually change it. Please check this link for some help.

share|improve this answer
    
that did the trick - still getting the error messages (which I think are coming from gnome-display) but - but it saves me from re-writing my xconf on each reboot. Thanks a million –  sunwukung May 15 '12 at 9:47
    
That is a bit wierd. I see no reason why would Your Gnome/Unity send errors. Please make a new thread about it. –  Misery May 15 '12 at 10:31
    
Ah, did another reboot to reproduce - error messages have disappeared too. One change, told Launcher to use laptop rather than both screens. –  sunwukung May 15 '12 at 12:57
    
This worked for me, however in my case i didn't have any xorg.conf file to begin with... d'oh! –  Michael Butler Jan 13 '13 at 15:27
add comment

Got it working (At last!!!)

installed 173 updates: https://launchpad.net/ubuntu/+source/nvidia-graphics-drivers-173-updates/173.14.35-0ubuntu1/+build/3597638

then ran :

sudo nvidia-xconfig --separate-x-screens

rebooted with 2 screens!!! SWEEEET!


UPDATE

: problem .. the '--separate-x-screens' options is not the right option. try:

WARNING "--force-generate"* will overwrite your current xconf.org

sudo nvidia-xconfig --twinview --use-edid-freqs --force-generate --mode=1920x1600 -T


P.S. My Setup:

  • GeForce FX 5200
  • 2 Dell flat screen monitors
  • Ubuntu 12.04

.

sudo lspci | grep VGA

01:00.0 VGA compatible controller: NVIDIA Corporation NV34 [GeForce FX 5200] (rev a1)

nvidia-xconfig --query-gpu-info

Number of GPUs: 1

GPU #0:
  Name      : GeForce FX 5200
  PCI BusID : PCI:1:0:0

  Number of Display Devices: 2

  Display Device 0 (CRT-0):
     EDID Name             : DELL2407WFPHC
     Minimum HorizSync     : 30.000 kHz
     Maximum HorizSync     : 83.000 kHz
     Minimum VertRefresh   : 56 Hz
     Maximum VertRefresh   : 76 Hz
     Maximum PixelClock    : 170.000 MHz
     Maximum Width         : 1920 pixels
     Maximum Height        : 1200 pixels
     Preferred Width       : 1920 pixels
     Preferred Height      : 1200 pixels
     Preferred VertRefresh : 60 Hz
     Physical Width        : 520 mm
     Physical Height       : 330 mm

  Display Device 1 (DFP-0):
     EDID Name             : DELL 1708FP
     Minimum HorizSync     : 30.000 kHz
     Maximum HorizSync     : 81.000 kHz
     Minimum VertRefresh   : 56 Hz
     Maximum VertRefresh   : 76 Hz
     Maximum PixelClock    : 140.000 MHz
     Maximum Width         : 1280 pixels
     Maximum Height        : 1024 pixels
     Preferred Width       : 1280 pixels
     Preferred Height      : 1024 pixels
     Preferred VertRefresh : 60 Hz
     Physical Width        : 340 mm
     Physical Height       : 270 mm

echo $(lsb_release -ds) $(uname -m) [$(uname -r)]

Ubuntu 12.04.1 LTS i686 [3.2.0-34-generic-pae]

dpkg --get-selections | grep nvidia

  nvidia-173                    install
  nvidia-173-updates            install
  nvidia-common                 install
  nvidia-settings               install

.

apt-show-versions | grep nvidia

nvidia-173/precise-security uptodate 173.14.35-0ubuntu0.2
nvidia-173-updates 173.14.35-0ubuntu1 newer than version in archive
nvidia-common/precise-updates uptodate 1:0.2.44.2
nvidia-settings/precise uptodate 304.64-0ubuntu1~precise~xup1

Hope this helps someone.. coz it took me forever to get this to work.

Here's what I've already tried:

  • Tried downgrading X server to get xorg-video-abi-11 to work... no joy as nvidia software needed other files in the newer x-server
  • Tried installing nvidia-current... not compatible!
  • Default Neauvou Driver doesn't support Unity 3D!
  • Added ppa:ubuntu-x-swat/x-updates. didn't support my card. dependency issues.

If anyone else has had success with this please let me know.. I might be doing it wrong.

share|improve this answer
add comment

(Just to add some information). I also experienced the same problem. But in my case I believe it was caused by trying to use the "Displays" utility. This utility does not seem to be compatible with the NVidia Settings tool.

So somehow you end up with an invalid xorg.conf. Deleting the xorg.conf as mentioned above, using the NVidia tool to recreate a new configuration, and logging out/back in to restart the X server worked for me.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.