Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The Fn key wont work on Toshiba satellite L735 on ubuntu 12.04 so anyone can help me please ???

share|improve this question
    
Maybe a stupid question but: Did it work with Windows OS? –  Misery May 15 '12 at 8:03
    
i wnat correct driver for toshiba L735 becous before my laptop when press FN key then show f1 f2 f3 this key now stop ready mean dont show –  user141248 Mar 18 '13 at 2:48
add comment

4 Answers

I have a Toshiba Satellite L510 with Ubuntu 12.04, I fixed this issue installing fnfx-client. And after installed, it worked automatically!!!

sudo apt-get install fnfx-client

Good luck!

share|improve this answer
add comment
sudo setpci -s 00:02.0 F4.B=X

Where x is 0-99, and 0 turns the display off. I have a Toshiba Satellite t135-S1309 and this was the only command I ever found to change the brightness. It's possible to set it up to bind to the keys or to set a brightness on boot, but I was never bothered by it to that degree. Not a perfect fix but it will change your brightness.

share|improve this answer
add comment

I had a similar problem with my Toshiba R830. What worked for me was the following changes to Grub:

Press Alt + F2 and type gksu gedit /etc/default/grub

Find the line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" and modify it to one of the following:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

or

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux"

or

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor" (this is what worked for me but others had success with the former)

Save and close gedit.

Open a terminal (ctrl + alt + T) and type sudo update-grub. Reboot your pc after each try.

Hope this helps.

share|improve this answer
add comment

I had the same problem on my Toshiba

i installed fnfxd package search synaptic Package Manger for it

it solved my problem

hope it helps u too

please note the difference between fnfx and fnfxd the latest one solved my problem

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.