Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

04, and when I open my php project and Scan completes a bar appears with "Please wait..." written on it. As I understood from reading forums etc that's the problem with the enter key.

share|improve this question
add comment

4 Answers 4

I use netbeans 7.0.1 on debian and fixed the issue by klicking on the info icon left to the <?php and then selecting "Change project default to HTML 4.01 Transitional"

It seems that the default is HTML 5 - and this generates a parser Exception. After switching the project default to the above mentioned setting I could use ENTER as normal - even on newly opened files.

share|improve this answer
1  
thanks a lot , amazing how this can be related to such a thing as the html parser –  maazza May 6 '13 at 7:04
    
I can't make the project, so how to write <?php and then project setting ....I'm also using netbeans 7.0.1 in debian –  user182904 Dec 30 '13 at 16:34
add comment

i'Ve just install an upgrade of ubuntu and therefore netbeans.. I have to say, this upgrade was a lot of work.

On the 1st run of netbeans i got:

cannot find an htmlParser implementation for HTML5

after a search i've decided to:

  1. download an install the latest version from http://netbeans.org/downloads,
  2. followed the instructions here, http://netbeans.org/community/releases/71/install.html
  3. After the installation wizard i imported my settings from 7.0 and everything is smooth again.

-To run the install file use sh [filename] -I saw somewhere that if you install using sudo, you will install for all users. can someone confirm that?

share|improve this answer
add comment

Workaround: When I add the line DOCTYPE tag the editor automatically accepts ENTER key again, try adding this at the top of the file and when done editing you can remove it:

<\!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
 "http://www.w3.org/TR/html4/loose.dtd">
share|improve this answer
    
This is basically the same as the answer by Croydon, right? –  gertvdijk Jul 14 '13 at 13:29
add comment

You can click on the icon displaying the error and changing to 4.1 STRICT

The best way is to update the IDE.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.