Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I solved one problem only to get a follow-up problem.

I have Win 7 and I tried loading 32-bit Ubuntu 11 on the system. It kept failing. I figured out due to another post here that it was because my 3TB drive was too much for it. After repartitioning the HD my friend and I managed to load it onto the system, but it was buggy when it came to updates, so I tried upgrading to Ubuntu 12 (32 bit), but I was still having the too many bits problem.

Plus now it seems like something is wrong with loading anything. Both Win 7 and Ubuntu are there, but neither will load. I get a mostly blank screen with the words:

**error: no such device: 3a0d062c-5f69-4635-9c79-3814c7d5bbed

grub rescue>**

(with what appears to be a command prompt)

I loaded U12, 64 bit version, in the hopes it would repair the boot issue. Everything appeared to install much more smoothly this time and update nicely, but there was no luck in the boot department. Again, all the data is there, but I'm still getting the black screen when I boot up. I've also tried the repair function in Win 7 with the install disk and no love. I can run from a liveCD, but that's still not getting me Win 7 or an installed version of Ubuntu.

I have confirmed both OS are there. Whatever prompts them to actually start seems to be the missing element.

Thank you in advance.

I've tried the terminal commands mentioned below. I get to the third command and:

ubuntu@ubuntu:~$ sudo mount /dev/sdb3 /mnt ubuntu@ubuntu:~$ sudo    mount ~bind/ dev/mnt/dev mount: mount point dev/mnt/dev does not    exist 


ubuntu@ubuntu:~$ sudo mount /dev/sdb3 /mnt mount: /dev/sdb3    already mounted or /mnt busy mount: according to mtab, /dev/sdb3 is    already mounted on /mnt 


ubuntu@ubuntu:~$ sudo mount ~bind dev    /mnt/sdb3 Usage: mount -V                 : print version


 ubuntu@ubuntu:~$    sudo mount --bind/proc/mnt/sdb3 mount: unrecognized option    '--bind/proc/mnt/sdb3' Usage: mount -V                 : print    version


 ubuntu@ubuntu:~$    sudo mount --bind/proc /mnt/proc mount: unrecognized option    '--bind/proc' Usage: mount -V                 : print version

share|improve this question

Boot from Ubuntu Live CD.

Open the Terminal.

Mount the partition your Ubuntu Installation is on. If you are not sure which it is, launch gparted (included in the Live CD) if not then install it via software centre and find out. It is Usually a EXT4 Partition. Replace the XY with the drive letter, and partition number.ex: sudo mount /dev/sda5 /mnt. Then bind the directories, you need, like so:

sudo mount /dev/sdXY /mnt

sudo mount --bind /dev /mnt/dev

sudo mount --bind /proc /mnt/proc

Now we jump into that using chroot.

sudo chroot /mnt

Now to install, check, and update grub you only need to add the partition letter (usually 'a') to replace X ex: grub-install /dev/sda, grub-install –recheck /dev/sda

grub-install /dev/sdX

grub-install --recheck /dev/sdX


Now you can exit you mounted hard disk,


sudo umount /mnt/dev

sudo umount /mnt/proc

sudo umount /mnt

Now restart and in terminal

sudo update-grub

Source >> How to Repair/Restore/Reinstall Grub 2 with a Ubuntu Live CD

share|improve this answer
I got a little further. TY. But I get stuck at the 3rd command. – GrayArcadian May 15 '12 at 19:17
Posted below is the terminal screen. – GrayArcadian May 15 '12 at 19:25
Well then do a fresh install of ubuntu , if windows is not detected , then on first run of Ubuntu , run this sudo update-grub This should solve the problem, or if it doesn't use Boot-Customizer to make windows detectable. Thanks for trying though. – atenz May 16 '12 at 12:37
Okay, problem solved. I am reporting on how: I followed the instructions here:… – GrayArcadian May 17 '12 at 3:29
@ GrayArcadian - Please post your solution as an answer and accept it as answer. It will be more helpful for others. – atenz May 17 '12 at 8:28

If not for Boot loader problem ,it seems Windows 32 Bit installation is the problem.

Try this Installer Only Recognizes 801GB of a 3TB RAID1 Array

Trouble creating 3TB ext4 partition due to msdos-partition-table-imposed error

Or for more info

share|improve this answer
Can I have a little more information on "windows 32 bit is the problem?" I am in way over my head here, tech-wise. Most of those articles I read before this. This how I discovered 32-bit + 3tb HD = bad, but beyond that it does not look like these articles are addressing my current problem, though I may be wrong. – GrayArcadian May 15 '12 at 9:30

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.