Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an open, unsecured router which I can connect to without any issues while in Windows.

When I am in Ubuntu, if I click on my wireless manager to see all the networks, then it shows all the secured networks around me but does not show my unsecured one.

I looked all over the place for a setting that could maybe filter out open networks and not show them. But I did not find anything. I do not know what is going on.

I often use the networks at Starbucks and hotels because I travel a lot. This is going to be a big problem for me. Can someone please point me in some direction?

I am using Ubuntu 10.04 with all updates applied and installed. I'm also using a Hawkings Wireless USB card. It uses the rt73 drivers that come installed default.

share|improve this question
    
You might need to change the broadcasting channel, most routers have a setting for that. To figure out what channel to pick, look at the output of nm-tool, and of sudo iwlist wlan0 channel. –  mikewhatever May 15 '12 at 4:23
    
I've tried to change the channel already I didn't think to mention that. Still didn't help. –  Screaming Midget May 15 '12 at 4:33
    
You are not hiding the SSID of that router/WAP, are you? –  irrational John May 16 '12 at 0:46
add comment

1 Answer 1

Try connecting from the terminal and setting your IP manually

iwconfig [interface] mode managed key open
iwconfig [interface] essid [ESSID]

Set your IP Address ifconfig [interface] [IP address] netmask [subnetmask]

Add ip of router as default gateway route add default gw [IP of default gateway]

Configure dns echo nameserver [IP address of DNS server] >> /etc/resolve.conf

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.