Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently switched from 10.04 to 12.04. I did a fresh install. However I can't configure 5.1 surround with my coaxial/SPDIF home teather, simply because the new sound manager interface doesn't provide options like in 10.04. In 10.04 I could configure 'digital output + analogic input' and everything was ok, but in 12.04 I can't do this.

enter image description here

How can I change the configuration?

share|improve this question
    
if you are happy with the answer - please click the tick button next to the answer to close this thread. Thanks. –  fossfreedom Jun 6 '12 at 8:54

2 Answers 2

Sounds like you have the same problem we have here, though in the opposite direction. Our fresh install of 12.04 32 bit won't let us switch from digital output to analog. Default will go to analog only if no other sound card hooked up (ie remove USB headphones).

screenshot of pavucontrols configuration dialogue

There is an option in pavucontrol to select between digital and analog outputs but it is not recognized by the default volume control and multiple outputs are not possible (application switching between streams is disabled).

Try pavucontrol and see if you can access the additional configuration there?

Alternatively you can do the configuration with pactl via terminal, see the manpage for more details. Also you should check the alsamixer settings in terminal, sometimes you try searching the root cause in pulseaudio, while its alsa instead.

alsamixer

share|improve this answer

Ubuntu disables and hides digital audio output SPDIF in all Realtek / Nvidia Cards by default in fact it does same in all flavor of Ubuntu.

The procedure to fix it is the same in all versions of Ubuntu and works for all sound cards Ati Nvidia Realtek Creative Bosse etc. You need to edit a file to get it to work. Open a terminal with CtrlAltt and type this:

sudo nano /etc/modprobe.d/alsa-base.conf

then add this line to the end of the file

options snd-hda-intel model=auto    

then use Ctrlo to save the file and Ctrlx to exit.

At this time you need to reboot the machine, and the missing digital audio spdif will be working. Go to task bar icon to select proper device (which will be showing now) to avoid sound output to all speakers at the same time.

For spanish take this link: http://www.fermu.com/es/articulos/linux/48-ubuntu/773-configurar-audio-hdmi-a-trav%C3%A9s-de-una-tarjeta-gr%C3%A1fica-nvidia-geforce-8600m-gt-en-ubuntu

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.