Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I actually like the global menu of Unity.

However, for GIMP, it's totally broken and terrible. Gimp uses multiple unassociated windows for its toolbars, and as soon as a toolbar gets focus the global menu disappears because the window the menu belongs to is not focused. So you have to switch focus back to the main image window. It's painful because you need to alternate between using toolbars and using the menu all the time, but every time you use the toolbars the menu disappears.

My question:

  • Is there any way to improve this behaviour in GIMP? Eg, by not having the toolbars as separate windows, or by setting compiz so it doesn't treat them as such?

  • Or failing that, how can I disable the global menu just for one application?

Using precise, with Gimp 2.6.12-1ubuntu1

share|improve this question

4 Answers 4

up vote 10 down vote accepted
+50

If you want one particular application to not use the global menu you can set a little known (but very useful) environment variable: UBUNTU_MENUPROXY=0

Thus, the following entered in a terminal will start gimp with the global-menu disabled:

UBUNTU_MENUPROXY=0 gimp-2.6

enter image description here

You'll note the global menu is disabled for Gimp - it's now with the main Gimp window.

As a suggestion, if you launch Gimp via a launcher icon, copy the /usr/share/applications/gimp.desktop file to your home folder ~/.local/share/applications (create if necessary).

Change the exec= value to a script file - for example /home/dad/launchgimp.sh

Copy and paste UBUNTU_MENUPROXY=0 gimp-2.6 into this new file and give it execute rights (chmod +x ~/launchgimp.sh)

Logout and login.

share|improve this answer
1  
This is an excellent answer, thanks. I haven't forgotten about the bounty and this answer will most likely get it. –  neon_overload May 21 '12 at 2:55
    
Bounty awarded thanks –  neon_overload May 24 '12 at 5:08

Possibly easier is to edit the Exec field in /usr/share/applications/gimp.desktop to

Exec=env UBUNTU_MENUPROXY=0 gimp-2.6 %U
share|improve this answer

This problem has been solved with the latest version of Gimp, In Gimp 2.8 you can use single window mode, Hence no more disappearing global menu.

Installing Gimp 2.8:

Gimp 2.8 can be installed by adding PPA for Ubuntu 12.04. Follow these steps:

  • Before installing Gimp 2.8 its important to remove the old version of Gimp.
  • Hit Alt+Ctrl+T to open terminal and run following commands:

    sudo apt-get autoremove --purge gimp
    
  • Run the following commands to add the PPA and install Gimp 2.8.

    sudo add-apt-repository ppa:otto-kesselgulasch/gimp
    sudo apt-get update
    sudo apt-get install gimp
    

How to enable single window mode in Gimp 2.8?

Open Gimp and goto Windows menu and select Single-Window Mode

That's it!

share|improve this answer
    
Thank you for the suggestion, but I was looking for a solution that could work with the existing Gimp in Ubuntu. I look forward to Gimp 2.8 making it in some time in the future, though. –  neon_overload May 15 '12 at 2:06
    
Gimp 2.8 is out and it is said to be stable. It is not in the 12.04 repositories and if things work as usual in Ubuntu, probably won't be there until 12.10. I suggest either to use the GIMP PPA to install 2.8 and enable single window mode (windows menu) or disable global menu as suggested above. –  To Do May 19 '12 at 16:24
    
I installed Gimp 2.8 from the PPA without removing 2.6 and nothing broke. It seems everything is working properly. –  To Do May 19 '12 at 16:25
    
I'm glad that replacing Ubuntu's Gimp with a newer version from a PPA worked out well for you. Unfortunately however it's not the solution I wanted, but that doesn't mean it won't be beneficial to others who are reading this. –  neon_overload May 22 '12 at 2:50
    
The Gimp is included in Ubuntu 12.10's repos –  Flimm Jan 21 '13 at 20:34

1 . Open the file for editing:

sudo gedit /usr/share/applications/gimp.desktop

2 . Locate the following line and delete it

Exec=gimp-2.8 %U

3 . Insert the following line

Exec=env UBUNTU_MENUPROXY=0 gimp-2.8 %U

4 . Also in the top of the file add the following line

#!/usr/bin/env xdg-open

See the file contents in the picture below: http://i.stack.imgur.com/PZTur.png

See the result in the picture below: http://i.stack.imgur.com/rkl83.png

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.