Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In my present configuration, my /home lives on a regular spinning hard drive, with the exception of /home/mac/runtime which is a partition from a SSD.

My problem is that such partition shows up as a "removable device" even if the mount options are such that is not possible for the user to unmount it at all (besides, it is not a removable device, given that it is a partition of an internal hard drive!).

Indeed my goal would be for the partition layout to be totally transparent (my /boot is on another disk too, but the user wouldn't know, and the /boot doesn't appear as a removable drive).

The portion of my /etc/fstab of interest looks like this:

# /home was on /dev/sdb1 during installation
UUID=<my-uuid-here>  /home              ext4  noatime,nodiratime   0  2  
# /home/mac/runtime was on /dev/sda3 during installation
UUID=<my-uuid-here>  /home/mac/runtime  ext4  noatime,nodiratime   0  2 

Thank you in advance for your help!

share|improve this question
    
What happens for / ? –  jasmines May 15 '12 at 5:30
    
@jasmines - Not sure I got your question right. Hope this is what you want to know: / works as expected (it doesn't show up as a removable drive). Physically, that is another ext4 partition of the SSD. –  mac May 15 '12 at 7:59
add comment

3 Answers

Rather than additionally mounting subdirectories of an already mounted drive let me suggest you mount it separately. You may then create a symlink to that directory in your HOME to make it accessible.

sudo mkdir -p /media/runtime

Then mount your SSD partition to `media/runtime or edit your /etc/fstab:

UUID=[uuid] /media/runtime ext4 relatime,errors=remount-ro,discard 0 2

Replace [uuid] by the UUID of your drive. To grant access to this partition create a symlink in your HOME:

ln -s /media/runtime /home/mac/
share|improve this answer
    
Hi, thank you for the suggestion, that I followed and made me discover a few more mounting options... However, even following your advice, the problem still persist. The partition shows up as a removable media. :( –  mac May 15 '12 at 14:54
add comment
up vote 0 down vote accepted

After having done some more research I found out that Fedora 16 experienced the same problem. I consequently filed a bug on launchpad and from the subsequent discussion it appears that the behaviour is due to the hot-pluggable nature of SATA devices.

share|improve this answer
1  
You may also be interested in this question: askubuntu.com/questions/133802/… and the GNOME bug: bugzilla.gnome.org/show_bug.cgi?id=660595 –  zigg May 15 '12 at 16:34
    
@zigg - Thank you, interesting indeed! –  mac May 15 '12 at 19:10
add comment

Pretty oldish now but I believe, should you wish, you can disable the hotplug features through kernel options (re-compiling a kernel).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.