Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

There seems to be lag whenever I start typing something in dashboard search, looking for an application. This could potentially be very fast, like typing Win "dwar" enter, runs dwarf fortress. But there's a lag while typing "dwar", starting on the letter "d".

I believe this lag is caused by the system fetching the icons. I'd like to disable this function and have the dashboard be text-only.

Note: the hud only has to show one icon at a time and look how much faster that is? It must be the icons.


edit: Note that I'm currently running Ubuntu 2D.

share|improve this question

You can not disable icons at the moment, unless you want to delete all your icon sets (you dont). But icons arent what is slowing your dash. The main cause is the blur in the background of the dash, that can cause a second of lag. Through compiz config (ccsm) you can disable blur, or set it to static.

Disabling blur makes the dash faster, but it can make reading the dash text difficult. Static blur is again faster than active blur, the only difference is that the image behind the dash doesn't change (example if a popup appears awhile the dash is open, you won't see it appear behind.

I highly recommended you try the blur options. Also use 12.04, unity is much faster! Unity 2D also offers a nice speed boost.

share|improve this answer
Your logic right, but I'm not running compiz. I'm already on Unity 2d. However, there is a blur effect in Unity 2d. – Isaac May 15 '12 at 1:46
Ah, well that's a completely different story then. What you can try to do is disable some effects in Unity-2D, using this handy tool:… Once installed, uncheck "enable compositing", and you should see a lighter experience. This may be a long shot, but give Unity 3D a shot with my tip on the no blur or static blur. You can even go as far as to disable shadows and other fancy effects. Personally I run Unity 3D on my cheap 5 yeah old netbook, with all effects and snappy. 12.04 rocks :) – Dominic Jordan Hasford May 15 '12 at 2:42
I've had stability issues when trying to run lots of stuff at once in Unity 3d. Unity 2d seems to be able to take a punch much better. As for your link, I've turned off "composting" using ubuntu-tweak, but part of the dash stayed blurred and transparent. But I'll try this other app and see if it works. – Isaac May 15 '12 at 4:00
If I answered your question correctly, could you mark it as solved so others can find it? – Dominic Jordan Hasford Jan 30 '13 at 16:01

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.