Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Gimp is nice, but the one thing that drives me nuts is that everything floats around in front of each other, often hiding the main window and forcing me to minimize all open windows until I find the one floating window that I am looking for.

I'd like to have the floating windows docked along the edges of that main window, the way practically every other application works. I know this floating thing is one of the things that make Gimp special, but it's not the kind of "special" that I like... I don't have a huge screen, so it quickly gets too cramped. And I often use Gimp briefly, multitasking with other apps, so the many Gimp windows are annoying.

How can I make Gimp run in one window, with everything else inside it?

This is Gimp 2.6.11 -- just because that's what came with my Ubuntu 11.10 installation.

share|improve this question

4 Answers 4

up vote 78 down vote accepted

Sorry, but you can't make a single window in GIMP 2.6!

If you want a single window in GIMP, you need to update to 2.8. Just follow the next instructions:

  1. Add the GIMP PPA. Open the terminal and copy/paste the following command: sudo apt-add-repository ppa:otto-kesselgulasch/gimp && sudo apt-get update
  2. Update GIMP using Update Manager or apt-get.
  3. Open GIMP, and go to Windows > Single-Window Mode

Now you have a single window! For example, my GIMP main menu:

enter image description here

share|improve this answer
    
Yay, I think this is exactly what I'm looking for! Thanks, I'll check it out. –  Torben Gundtofte-Bruun May 14 '12 at 21:21
1  
Great answer, just not entirely true: there is a way to make Gimp 2.x a single window application. Not out of the box and I would recommend updating to 2.8 too, but you can do it: webupd8.org/2011/06/gimpbox-get-single-window-mode-in.html –  rearlight May 15 '12 at 8:56
    
Just tried this on 11.10 (same as OP) and I get 'CAUTION! This PPA could break your installed OS. There are dependency issues for Oneiric Ocelot (11.10). Only use it if you know what you do!' No thanks, is there a better way to do this? –  Tom Brossman May 15 '12 at 18:34
2  
"Otto Kesselgulasch"? Is that for real? Is that the official source? –  Torben Gundtofte-Bruun May 15 '12 at 18:46
1  
I had an error upgrading GIMP as instructed. However, I solved this: I uninstalled GIMP, and then reinstalled successfully. –  Paddy Landau May 22 '12 at 9:48

Select "Single-Window Mode" from the Windows menu item. The setting will persist between GIMP launches, and is only available for GIMP version 2.8 and over. ( How do I get GIMP 2.8? )

Screenshot of GIMP 2.8, with the Windows menu open and Single-Window Mode selected

share|improve this answer
    
This solution does not work with Gimp 2.8.10 on Ubuntu 14.04. –  Luís de Sousa Oct 26 at 18:10

Gimp 2.8 is capable of doing what you want. You can grab the source from here: ftp://ftp.gimp.org/pub/gimp/v2.8/ and compile it on your own. This runs in single window mode.

share|improve this answer
5  
Compile? I use Ubuntu because I'm not a Linux expert :-) –  Torben Gundtofte-Bruun May 15 '12 at 18:55
    
I usually also prefer pre-compiled binaries, but for Gimp 2.8 there actually is a really nice step by step guide on how to compile it: gimpusers.com/tutorials/compiling-gimp-for-ubuntu –  moeso Jun 7 '12 at 14:43
    
Compile is the easiest way to get something working on linux. Binary's come out later that code and often very late. –  Siddharth Jul 3 '13 at 9:43

There is an unofficial application to use Gimp 2.x in a single window mode called GIMPBox.

You can find all the info with installation guide about it here. It seems a bit complicated to install, but you will have a single window Gimp 2.6.

Personally, I would suggest you install Gimp 2.8. It's a stable release so there should be nothing to worry about. I use it too and the single window mode is awesome! Simply follow the instructions espectalll123 has given to install it and you are good to go.

share|improve this answer
    
I have followed the link, and I have run the codes given there but, after a general update of the system, I see this in terminal: W: Failed to fetch ppa.launchpad.net/ferramroberto/gimp/ubuntu/dists/precise/main/… 404 Not Found W: Failed to fetch ppa.launchpad.net/ferramroberto/gimp/ubuntu/dists/precise/main/… 404 Not Found W: Failed to fetch ppa.launchpad.net/ferramroberto/gimp/ubuntu/dists/precise/main/… 404 Not Found E: Some index files failed to download. They have been ignored, or old ones used instead. –  Cristiana Nicolae Oct 17 '13 at 7:56
    
@CristianaNicolae It seems like GIMPBox is only compiled for Ubuntu lucid, maverick, natty and oneiric. So precise (your version of Ubuntu) isn't supported. I would recommend you install the newest version of Gimp for single window mode (how you do it is written in the accepted answer to this question). –  rearlight Nov 8 '13 at 10:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.