Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On Ubuntu 12.04 LTS 64 bits, when I open a video with VLC, Mplayer, Gnome media player there is like a green filter. There is the same problem when I open a video in the web browser.
This look to be the same symptom than on this post All imported video is green in OpenShot but I never install Openshot.
Also every think work fine on MS-Win.
Please any idea to fix this ?

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

For vlc try changing your video output to OpenGL (preferences -> video -> output). You should be able to change it also for GStreamer based apps by running gstreamer-properities in your terminal.

share|improve this answer
    
Perfect. On my hardware, the vlc gave green. Changing the output to OpenGLX worked. As for gstreamer-properties command preferences, I had to change the default output plugin from autodetect to X Window System(No Xv) to make it work with mplayer. –  Thava Sep 30 '13 at 10:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.