Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Every time i am getting Unable to save resume file. Too many open files error in transmission application. I got solution in this post.

sudo sh -c "echo fs.file-max=$(dc -e '2 20 ^ p') > /etc/sysctl.d/file-descriptors-max.conf"
sudo service procps restart

But sudo service procps restart output:

stop: Unknown instance: 
procps stop/waiting

Can anyone please help me out? I am using Ubuntu 12.04 LTS.

share|improve this question
add comment

1 Answer

My current Ubuntu 12.04 installation shows 98930 as value for file-max

> cat /proc/sys/fs/file-max
98930

If you want to raise this value, you have several options.

  1. Create a new file: echo "fs.file-max=$(dc -e '2 20 ^ p')" | sudo tee /etc/sysctl.d/60-file-descriptors-max.conf. This command writes the echoed line into the file. If the file exists it is silently overwritten. According to the documentation you should choose the value 60-*.conf for user values. After you have done this you should enter sudo service procps start and not restart like in your example. As you can see with the command sudo service procps status the program is not running.
  2. Directly write into the file in the proc filesystem: echo $(dc -e '2 20 ^ p') | sudo tee /proc/sys/fs/file-max. After the command the value is set and will be used. You can use the above mentioned cat command to get the current value.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.