Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This is getting quite annoying and Google isn't proving to be much of assistance.

I've built a new server and it has a total of five devices.

/dev/sda - 2TB HDD

/dev/sdb - 2TB HDD

/dev/sdc - 2TB HDD

/dev/sdd - 2TB HDD

/dev/sde - 60GB SSD

I'm trying to install Ubuntu 12.04 Server amd64 on /dev/sde (60GB SSD). I use guided partitioning and use the entire disk (no lvm). All seems to be going well, it's getting near the end of the install and then when it tried to install GRUB, it fails. I suspect because it says it is trying to install to /dev/sda which I don't want it to. Those four 2TB drives I'm going to be configuring in an mdadm RAID5 array once I have Ubuntu installed on the SSD. Why is GRUB trying to install to /dev/sda and not /dev/sde?

share|improve this question
1  
Resolved. I was unaware you could choose "no" to not install the grub bootloader on the default screen. It then takes you to a screen that lets you choose which device to install it too. I simply choose "/dev/sde" and everything is working great! This option should be more noticeable. –  Ryan Mortier May 14 '12 at 17:07
    
Let's reopen this. It should never have been closed. When a question's author solves the problem and reports the solution, except when it is clear that the solution wouldn't help anyone else, it should be posted as an answer. Usually it's best to encourage the author to post their answer but posting it as a CW answer is also acceptable (as I have done). This does not (and never did) meet our criteria for abandoned. –  Eliah Kagan Mar 13 '13 at 2:27
    
@EliahKagan TL isn't just for abandoned. I will vote though. –  Seth Mar 13 '13 at 17:41
    
@Seth This never met any other criteria for closing as TL, either (as I suspect you agree, having reopen-voted). The key point is that this is an answered question and the question and answer are meaningful and will likely be helpful to other users. It's true that if the answer were something like "I gave up" then it should be TL even though it's not abandoned. But nothing like that applies here. –  Eliah Kagan Mar 13 '13 at 23:57
add comment

2 Answers

The OP solved the problem and gave the solution in a comment:

Resolved. I was unaware you could choose "no" to not install the grub bootloader on the default screen. It then takes you to a screen that lets you choose which device to install it too. I simply choose "/dev/sde" and everything is working great! This option should be more noticeable.

share|improve this answer
add comment

I am running into the same problem on Ubuntu server 13.10, and I have wasted much time dealing with it. It would be nice if you would make it clear that answering "no" at this step means that you can install the boot loader someplace else.

Perhaps a better solution would be the following:

  • put boot loader on MBR on /dev/sda
  • put boot loader in first sector of /dev/sda1
  • put boot loader on MBR of /dev/sdb
share|improve this answer
    
Also, there should be some information about the sizes of the partitions, to help the user figure out which drive is which. During the installation process, /dev/sda is the USB drive (usually) and /dev/sdb is the target drive. But it doesn't have to be. Usually, if you tell the size of the drives, then the user can figure it out easier. –  user1928764 Feb 13 at 21:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.