Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I also have to enter a password to connect. Not the root password, but a password I created for the DSL connection when installing Ubuntu.

So I would like to get rid of the password and connect automatically at startup.

share|improve this question
    
does the modem (if you are using one) have an ethernet connection available? –  RolandiXor Nov 17 '10 at 14:09
    
@Roland Taylor Yes, it does. It's the Speedtouch modem. –  Joshua White Nov 17 '10 at 15:50
add comment

2 Answers

up vote 2 down vote accepted

I suggest you use pppoeconf.

Press Ctrl+Alt+T or go to Applications -> Accessories -> Terminal. Run:

sudo pppoeconf

Set the username and password.

Now to connect, run this pon command in the terminal:

sudo pon dsl-provider

To disconnect:

sudo poff

We really want it to connect automatically though, so edit /etc/rc.local by running:

gksu gedit /etc/rc.local

That opens the file in a text editor. Before the line that says exit 0, add these lines:

# For PPP auto-connect.
killall pppd
ifconfig eth0 up
pon dsl-provider

Save file and quit the text editor.

Now, reboot the system.

If you want to use Network Manager, see this articlepost:

share|improve this answer
    
Based on the post you linked, my provider is trying to connect automatically, but Ubuntu is asking for a password. Again, it's not the root nor the service provider password, it's a password I created for the DSL connection when installing Ubuntu. I have the 'Connect automatically' box checked. So my only problem seems to be the password preventing it to connect automatically. –  Joshua White Nov 17 '10 at 15:53
    
I was wrong. 'Auto eth0' was connecting automatically. I checked the 'Available to all users' box and followed your instructions. Now it's connecting automatically. Checking the 'Available to all users' box prevent it from asking for the password. Thank you. –  Joshua White Nov 17 '10 at 16:52
    
Glad it worked :) –  karthick87 Nov 17 '10 at 17:44
add comment

If you have it set up with a default account that bypasses the login screen then this is an issue with the keyring. You need to go to

System > Preferences > Passwords and Encryption Keys

You need to delete the Default Keyring and set the Login Keyring as default. I think it might require a restart for it to show up.

share|improve this answer
    
I deleted the Default keyring and set the Login keyring as default and restarted. It was not connecting. I had to delete that connection and create anther one. After I created another one, it started asking for the password again. I checked the 'Available to all users' box and it stopped asking for the password. –  Joshua White Nov 17 '10 at 16:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.