Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I start some applications like Gimp or update-manager they start like if they where maximized but they have window decorations, are not integrated into the Unity panel and therefore move towards the screen bottom. I also tried to force maximize behaviour via compizconfig-settings-manager but that doesn't change anything.

What can I do to start these applications maximized with integration into the Unity panel? enter image description here

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted
+50

gDevilspie can do that for you!

What is gDevilspie?

A user friendly interface to the Devil's Pie window matching daemon, To create rules easily.

Devil's Pie is a window-matching utility, It can be configured to detect windows as they are created, And match the window to a set of rules. If the window matches the rules, it can perform a series of actions on that window.

How to install gDevilspie?

Hit Alt+Ctrl+T to open terminal and run following command:

sudo apt-get install gdevilspie

Or search for gDevilspie in Software Center and install from there.

How to use?

  • Once installed, Hit Super key (Windows key) to open Unity dash and search for "gDevilspie" and open it.
  • Open "Gimp".
  • In gDevilspie click on "add" to add a new rule.

  • In "Rule Editor" Click on "Get", Select Gimp window and "Apply".

enter image description here

  • Name this new rule as "Gimp" in top field.
  • Under "Matching" tab enable "window_xid" and "application_name"

enter image description here

  • Under "Actions" tab enable "maximize" and click save.

enter image description here

  • On the main window enable the option "Start devilspie daemon automatically at login" and click on "Start". That's it!

enter image description here

Now whenever you will start "Gimp" it will automatically be maximized. You can add rules for "Update Manager" or any other program in the same way.

share|improve this answer
    
Thanks a lot for the really nice tutorial. I stumbled upon devilspie before but I chose the wrong settings. Nevertheless I'm wondering if it's a Compiz bug because using devilspie is only a workaround. –  joschi May 18 '12 at 9:45
    
I think it's a problem of Gimp not Ubuntu, Because most of the applications work very nicely with Unity. –  Basharat Sial May 18 '12 at 10:07
1  
I have (now had :-) ) this problem with a lot of applications like update-manager, gnome-system-monitor... So I don't think it's Gimp causing it. –  joschi May 18 '12 at 10:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.