Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Tried all possible ways to give visibility to tray icons in Ubuntu 12.04 but no luck :(

  • Dconf-editor -> Navigate to Desktop -> Unity -> Panel -> change the value of systray-whitelist to "all"
  • gsettings set com.canonical.Unity.Panel systray-whitelist "['all']"
  • Set values of above to include pidgin, davmail, etc.

Please note that only some tray icons are invisible. I still cant see pidgin, davmail, guake tray icons. I am on Ubuntu 12.04 Gnome classic mode (gnome-session-fallback).

share|improve this question
1  
I probably see a mistake here: dconf-editor is for unity. gnome classic probably uses the old gconf so you need gconf-editor (will remove if wrong assumption). –  Rinzwind May 14 '12 at 10:32
1  
This seems to be a bug with Ambiance and Radiance themes. Try Adwaita. –  mosno May 20 '12 at 15:24
    
If this is due to a bug, it would be good to report it as one. –  Eliah Kagan Jun 5 '12 at 8:12
    
Some related questions: askubuntu.com/questions/343788/… and askubuntu.com/questions/166267/… –  Mark Butler Jan 16 at 15:47
add comment

3 Answers

up vote 6 down vote accepted

The solution is to add the Notification Area applet. Taken from this question No Banshee notification area icon in Gnome 3 classic session

share|improve this answer
    
Thanks Vangop, that solved it. I was under the impression that indicator-applet-complete should handle this. Thanks again. –  Shrijit Jun 6 '12 at 12:45
    
Can you plz mark it as answered then. –  vangop Jun 9 '12 at 5:02
    
Thanks a lot, this also works for the missing tray icon of Shutter. –  boundaryfunctions Nov 27 '13 at 7:55
add comment

I have just solved this problem with davMail on xubuntu using the following method:-

  1. Open the task manager and if davmail is running, kill it.
  2. Open a terminal and type sudo apt-get install libswt-gtk.
  3. Re-start DavMail and you should see the icon in the notification area.

It took me along time to find the solution, but it is quick and simple to do.

share|improve this answer
add comment

Have you added the indicator applets to your panel? This might help: I can't add a Indicator Applet to Panel in Gnome-Classic

share|improve this answer
    
Yes, like in one of the comment in the link you mentioned, in 12.04, it is used by default in gnome-session-fallback. I have many tray icons, but there are some which do not seem to be visible like Pidgin, Davmail, etc. –  Shrijit May 14 '12 at 14:24
    
With pidgin, you can go to the preferences and set Show tray icon to Always. I guess the other apps have similar settings as they would otherwise use the indicator applets. –  Durand May 15 '12 at 18:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.