Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use a Lenovo Thinkpad X121e with an AMD E350 processor and Ubuntu 11.10 64bit running.

When listening to music on soundcloud or watching videos on youtube from time to time the sound gets chopped, being basically a sped-up and having gaps of ~50ms every ~100ms. This problem occurs using Chromium, Firefox or Opera, even though when for example sound in Chromium stops working and I open up Firefox audio might sometimes work while still not working in Chromium. When I open up "Sound Settings" and open the "Applications"-tab the program outputting the sound flashes up in approximately the same frequency the sound is chopped, then disappearing again and the message "No audio-application is recording or playing anything." (These translations might not be 100% correct since I'm using the german Ubuntu.) I only had this bug while using browsers so far, I use tomahawk for local music and I never faced anything similar there.

What temporarily fixes this almost always is opening up the audio-settings output-tab and then switching the output from "Internal Analog" to "Internal HDMI" and then back to "Internal Analog" again. After finishing the current track/video and playing the next, most likely the problem occurs again.

I would appreciate any help and if there are any log-messages or console-output I could post to make helping me easier, please just tell me. Below is the output of lspci:

00:00.0 Host bridge: Advanced Micro Devices [AMD] Family 14h Processor Root Complex
00:01.0 VGA compatible controller: ATI Technologies Inc AMD Radeon HD 6310 GraphicsATI
00:01.1 Audio device: ATI Technologies Inc Wrestler HDMI Audio [Radeon HD 6250/6310]
00:05.0 PCI bridge: Advanced Micro Devices [AMD] Family 14h Processor Root Port
00:06.0 PCI bridge: Advanced Micro Devices [AMD] Family 14h Processor Root Port
00:07.0 PCI bridge: Advanced Micro Devices [AMD] Family 14h Processor Root Port
00:11.0 SATA controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 SATA Controller [AHCI mode]
00:12.0 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:12.2 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:13.0 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:13.2 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 42)
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA) (rev 40)
00:14.3 ISA bridge: ATI Technologies Inc SB7x0/SB8x0/SB9x0 LPC host controller (rev 40)
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge (rev 40)
00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 0    (rev 43)
00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 1
00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 2
00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 3
00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 4
00:18.5 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 6
00:18.6 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 5
00:18.7 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 7
01:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)
02:00.0 Ethernet controller: Atheros Communications AR8151 v2.0 Gigabit Ethernet (rev c0)
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5116 PCI Express Card Reader (rev 01)

Thanks in advance.

Edit: I first thought this was flash-related, turns out I'm using the HTML5 version of youtube, so I guess I was wrong.

share|improve this question

1 Answer 1

The same started to happen to me after updating to Ubuntu 12.04 64-bit from Ubuntu 11.10 64-bit. As in your case, my audio device is

00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA) (rev 40)

Recently I found out that people have been coping with similar problems for years:

https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/572580

And, in comment #17, there was an advice how to disable pulseaudio for your user, by issuing the following commands in the terminal:

touch ~/.pulse-a11y-nostart
echo autospawn = no|tee -a ~/.pulse/client.conf
killall pulseaudio

It worked for me. While sound indicator became unavailable, I was able to succesfully run different players and watch flash videos in browser.

Hope that helps you.


Oh, and another thing. In Chrome, the sound became choppy because of two flash plugins were active at the same time.

At chrome://plugins/ I clicked "Details" button and disabled the one at

/opt/google/chrome/PepperFlash/libpepflashplayer.so

Not sure it was the right choice, but the choppiness has gone away.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.