Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

While trying to upgrade to 12.04 I encountered problems with my internet connection and therefore my upgrade got stuck mid-way. Since the computer froze I tried to reboot and constantly got the message: mountall: /lib/x86_64-linux-gnu/ version 'GLIBC_2.14' not found (required by /lib/

I ended up reinstalling 12.04 with a USB, re-adjusting the size of the partition and now it works fine. The problem is that the new upgrade has left without ANY of my documents and there were some hugely important ones, is there anyway to recover them? I cannot enter any of the previous lynux versions available on my laptop, any tips?

share|improve this question
Insert live cd and check whether the old partition is exist or not – Tachyons May 14 '12 at 10:24
I did and it does exist, what next? – Ticiana May 14 '12 at 14:26
Backup that files – Tachyons May 14 '12 at 14:49

Oh gosh... I'm sooo sorry! First off, you need to know that you are not the only one! It happens to all of us. When this happens to me, I tell myself that learning is NOT free. This upgrading feature should be disabled. I had a lot of problems with it too.

First off, you need to know how many partitions you already have on your computer. I guess you only have one hard drive right?

Go to your terminal and type : sudo fdisk -l

Please post here all your partitions that you have on your hard drive such as /dev/sda1, 2, 3 etc.. with the type 83, I guess you only have one partition?

You might be able to recover 'some' files... Most probably not all of them because you ended up reinstalling ubuntu probably on the same partition.

Try photorec application. Here it is: Another good one is

Remember that you will probably end up recovering your files bit by bit so there will be corruption in some while others will simply not be recoverable.

I know it's very frustrating. It happened to all of us. I guess that's the way we learn. Always make a backup!

Go to your ubuntu software center and type 'backup'. Install a backup software and start using it.

All of us have too much stuff to back up so we postpone to backup. My best suggestion is that you need to group what is important and what is not in your documents. Start by only backing up what is important to you... On a daily basis (or at the very least weekly). Keep a backup off site also. That way, if you get stolen, you will still have your offsite backup you'll be able to recover from.

Trust me, this happened to me too.


share|improve this answer
StepNjump: thank you so much for your help! I'm going to try this out!! – Ticiana May 14 '12 at 13:03
Yes, I have only 1 partition, so hopefully it will all go smoothly, definately will back up constantly from now on!! – Ticiana May 14 '12 at 13:05

and there were some hugely important ones

In case these data reside on a partition that was repartitioned and partly overwritten by a fresh installation, and if they are really that important with no backup at hand:

Stop using the disk!

Only then you make sure that the remainders of your data are not overwritten more and more. The less was written in addition on that disk the more chance you have to recover some of your files by data recovery tools such as Testdisk/Photorec (testdisk Install testdisk).

Testdisk should be installed and run from booting with a live CD. Have another drive at hand where you can store the recovered files.

See also: Is there a way to recover files from a storage device partially overwritten with dd?.

share|improve this answer
Thanks takkat! Will try this too!! – Ticiana May 14 '12 at 13:03
@Ticiana: hope you have some luck. The Photorec Wiki is a good place to learn how to do it. – Takkat May 14 '12 at 13:26
thanks so much! – Ticiana May 14 '12 at 14:29

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.