Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I play any video on Ubuntu 9.10, volume is not there. Is it lacking a package?

share|improve this question
1  
why dont you use the latest version 10.10? I think that would be the ultimate solution. –  Gaurav Butola Nov 17 '10 at 13:22

4 Answers 4

If you don't have sound when playing a video, here's some general advice:

  • Assume the simplest cause and work from there.
  • Does it depend on that video? Can you play a simple sound file (like one from this page) If the WAV file plays fine, it might be related to a missing audio codec, or to your media player application.
  • Is the volume up - both PCM and Master volume, if that applies to your case - and the sound not muted? You can check that by right-clicking on the volume meter in your systray.
  • Is your stereo properly connected and set up, no headphones plugged in?
  • Does sound work on another operating system?

If these do not point to a cause of the problem, it might very well be a driver problem. In that case you should:

  • Find out if your sound card was detected at all;
  • Use a more full-featured mixer program, such as alsamixer, and see if changing the settings has any effect;
  • Find out your audio chipset. This can be done by running lspci in the terminal and watching out for what loooks like a sound card;
  • Google that sound card, or the driver used for it. In some cases, adding a module option can bring the sound card to life.

If it is indeed a driver issue, it might help to check if the card works under Ubuntu 10.10 - you can verify this easily by using live media such as a CD or a USB stick.

share|improve this answer

Do you have the alsa-* package installed ?

Try with:

dpkg -l |grep alsa

share|improve this answer

if you cant upgrade to 10.10, try these:

sudo apt-get install ubuntu-restricted-extras package

sudo /usr/share/doc/libdvdread4/install-css.sh

sudo apt-get install gstreamer0.10-ffmpeg gstreamer0.10-pitfdll gstreamer0.10-plugins-bad gstreamer0.10-plugins-bad-multiverse gstreamer0.10-plugins-ugly gstreamer0.10-plugins-ugly-multiverse libdvdnav4 libdvdread4 libxine1-ffmpeg
share|improve this answer
    
ubc@ubc-desktop:~$ dpkg -l |grep alsasudo apt-get install ubuntu-restricted-extras package grep: apt-get: No such file or directory grep: install: No such file or directory grep: ubuntu-restricted-extras: No such file or directory grep: package: No such file or directory ubc@ubc-desktop:~$ its give some error when i use the given command –  shalu Nov 18 '10 at 4:46
    
@shalu: there is a small mistake in your command. dpkg -l |grep alsa and sudo apt-get install ubuntu-restricted-extras are two different commands and need to execute one by one. just run the above three commands one by one. you will be fine –  aneeshep Nov 18 '10 at 5:31
    
ubc@ubc-desktop:~$ sudo apt-get install ubuntu-restricted-extras package Reading package lists... Done Building dependency tree Reading state information... Done ubuntu-restricted-extras is already the newest version. E: Couldn't find package package –  shalu Nov 18 '10 at 7:07

If you're having problems with sound, click the Volume applet, then Sound Preferences, and check your Volume, Hardware, Input, and Output settings. If that fails, see

https://help.ubuntu.com/community/Sound

https://help.ubuntu.com/community/SoundTroubleshooting

http://alsa.opensrc.org/DmixPlugin

share|improve this answer
1  
The developers recommend wiki.ubuntu.com/Audio as a starting point. –  Daniel T Chen Dec 18 '10 at 20:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.