Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Dell Precision server with a PCIe FX100 KVM Host card installed (manufacturer is Teradici but it's rebranded as a Dell solution.)

I am not using this card (it's installed in the machine but not externally connected to anything), but I believe it's still overriding the onboard audio to be the default and only audio output. As such, the audio from the server is being routed to the KVM card. I do not want this to happen as I have speakers connected to the audio out jack.

Under System -> Preferences -> Sound, the only thing listed is "HDA Teradici", which is the KVM card.

According to the server's manual, the onboard audio is supposed to be "an integrated two-chip audio solution comprised of Sigmatel’s STAC9200 High Definition Audio CODEC and the ESB2’s integrated AC97/High Definition digital controller". However, it looks like the onboard sound has been disabled by the KVM card.

The only entry in /dev/snd/ is pci-0000:02:00.1, which is the audio interface on the KVM card (see lspci output below).

  • Where can I select to use the onboard audio instead of the KVM card?
  • If that's not possible, is it possible to disable the PCIe KVM card somehow? This is a remote machine so I'm not able to physically remove the card.

I would also appreciate any troubleshooting steps to point me in the right direction for where this card may be overriding things, any relevant logs, etc.


lspci output

lspci lists the following for the device:

02:00.0 USB Controller: Teradici Corp. Device 1200
02:00.1 Audio device: Teradici Corp. Device 1200

lshw output

and lshw has the following relevant section:

*-pci:1
         description: PCI bridge
         product: 5400 Chipset PCI Express Port 5
         vendor: Intel Corporation
         physical id: 5
         bus info: pci@0000:00:05.0
         version: 20
         width: 32 bits
         clock: 33MHz
         capabilities: pci pm msi pciexpress bus_master cap_list
         configuration: driver=pcieport
         resources: irq:73 memory:dbf00000-dbffffff
       *-usb
            description: USB Controller
            product: Teradici Corp.
            ...
            configuration: driver=ohci_hcd latency=0
            resources: irq:52 memory:dbffb000-dbffbfff
       *-multimedia
            description: Audio device
            product: Teradici Corp.
            vendor: Teradici Corp.
            physical id: 0.1
            bus info: pci@0000:02:00.1
            version: 00
            width: 64 bits
            clock: 33MHz
            capabilities: pm msi pciexpress bus_master cap_list
            configuration: driver=HDA Intel latency=0
            resources: irq:52 memory:dbffc000-dbffffff

pacmd list-cards output

and pacmd list-cards Lists only one card available (Which is why I'd assume I'm unable to select any others):

Welcome to PulseAudio! Use "help" for usage information.
>>> 1 card(s) available.
index: 0
name: <alsa_card.pci-0000_02_00.1>
driver: <module-alsa-card.c>
owner module: 4
properties:
    alsa.card = "0"
    alsa.card_name = "HDA Teradici"
    alsa.long_card_name = "HDA Teradici at 0xdbffc000 irq 52"
    alsa.driver_name = "snd_hda_intel"
    device.bus_path = "pci-0000:02:00.1"
    sysfs.path = "/devices/pci0000:00/0000:00:05.0/0000:02:00.1/sound/card0"
    device.bus = "pci"
    device.vendor.id = "6549"
    device.vendor.name = "Teradici Corp."
    device.product.id = "1200"
    device.string = "0"
    device.description = "HDA Teradici"
    module-udev-detect.discovered = "1"
    device.icon_name = "audio-card-pci"
profiles:
    output:analog-stereo: Analog Stereo Output (priority 6000)
    output:analog-stereo+input:analog-stereo: Analog Stereo Duplex (priority 6060)
    input:analog-stereo: Analog Stereo Input (priority 60)
    off: Off (priority 0)
active profile: <output:analog-stereo>
sinks:
    alsa_output.pci-0000_02_00.1.analog-stereo/#0: HDA Teradici Analog Stereo
sources:
    alsa_output.pci-0000_02_00.1.analog-stereo.monitor/#0: Monitor of HDA Teradici Analog Stereo
>>> 

aplay output

And aplay -l similarly only lists the Teradici device:

**** List of PLAYBACK Hardware Devices ****
card 0: Teradici [HDA Teradici], device 0: ALC883 Analog [ALC883 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
share|improve this question
1  
It could also be that the onboard audio is disabled in the BIOS, but I don't think this is the case, and as I can only access the machine remotely, it's difficult to test this. –  jozzas May 16 '12 at 4:55
2  
I had the same problem as you, and it was a BIOS problem. When I went into the BIOS, I was able to re-enable the integrated audio and everything worked as normal. –  John Farrelly Feb 22 '13 at 17:11
add comment

3 Answers 3

You should check in the BIOS on the server to make sure onboard audio is enabled. The Teradici card presents itself as an audio device which may trigger the BIOS to disable the onboard audio. You should be able to override this.

share|improve this answer
    
This is the first thing I should have done, but the server is in a very difficult to access location and there is no out-of-band management setup on this particular server, so I can't get at the BIOS. OOBM is definitely a requirement for similar applications in the future. –  jozzas Jun 20 '13 at 22:28
add comment

As something to try:

Unless the onboard hardware uses the same driver "snd_hda_intel" driver you could try editing the /etc/modprobe.d/blacklist file and adding:

blacklist snd_hda_intel

In order to stop the driver from starting and grabbing the KVM board.

Another more selective approach might be ignoring the device with a udev rule matching the unwanted device and specifying OPTIONS+="ignore_device" For more information on writing the rule see this.

share|improve this answer
add comment
up vote 2 down vote accepted

I had the KVM card removed from the server and the onboard audio was automatically detected. This card obviously isn't very well supported by the manufacturer in Ubuntu, so for anyone coming across this, I would suggest you go with an external KVM solution that isn't tied to your specific server hardware.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.