Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently bought a MSI-X370 laptop with ATI graphics and wiped Windows and replaced with Ubuntu 12.04.

Now, up until my upgrade from beta 2 to the first stable Ubuntu 12.04 release, I didn't have problems with this.

This is the problem: ACPI knows that my battery capacity is 4400mAh, but only randomly charges fully ever. Otherwise, it charges to around 86%, and I get a orange light blinking on the laptop, and my acpi -V says that I'm charged to 100%. The strange thing is, that I do a cat info again, and it is still not charged to capacity. Why the discrepancy? Did something change in acpi, upower, gnome-power-manager? I am lost, and no one seems to want to assist.

cat info: /proc/acpi/battery/BAT1$ cat ./info present: yes design capacity: 4300 mAh last full capacity: 4053 mAh battery technology: rechargeable design voltage: 14800 mV design capacity warning: 0 mAh design capacity low: 0 mAh cycle count: 0 capacity granularity 1: 1 mAh capacity granularity 2: 1 mAh model number: ?MODEL

serial number:

battery type: LION

OEM info: ?CUSTOMER

I am standing by for anyone's ideas

Thanks

share|improve this question
    
A - It is the original charger B - Not sure what you mean by this question. I'm on a USA power grid, just the regular 3-prong. The charger is rated for INPUT: 100-240V, 50-60hz OUTPUT: 19V (2.1A). The battery WAS giving me ~8 hours or so of life daily before I started seeing this problem, and now it only gives me ~4.5. –  linux_RRT May 14 '12 at 12:29
    
Thanks mateo for your input. The hours usage I gave you are with screen brightness at its minimum and with all networking disabled. After looking at this problem for ~1 month, I've narrowed it down to a discrepancy between the capacity reported in several softwares (unity panel, batmon, acpi). Do these softwares not communicate with a single battery operation module, or am I just making things up to make it feel like I'm getting somewhere? Thanks again –  linux_RRT May 14 '12 at 17:18
add comment

3 Answers 3

Flashing orange indicates there is a problem with the battery, http://forum-en.msi.com/faq/article/battery-led-is-blinking-orange

Blinking orange is battery failure, http://forum-en.msi.com/index.php?topic=125647.0

It may still be under warranty since is has been only 2 months, contact MSI about a replacement. If it is not covered by warranty you should buy a new battery.

share|improve this answer
    
Buying a new battery is no problem, I just don't want to be in the situation where I buy a new one only to have the same problem occur again. These batteries aren't cheap (~$100 each), so I'd much rather get to the root of the problem. Also, the battery is occasionally able to charge completely and the orange light stops flashing. How come Ubuntu doesn't have a better control mechanism for LiIon battery charging and general control? It seems like the battery control is spread out between different, unrelated softwares.. –  linux_RRT May 14 '12 at 17:13
    
Oh right, I forgot to say that my MSIx370 is no longer covered under warranty because I changed my HDD out for a SSD drive, so free battery is not going to happen. Also, what I noticed about the article posted above is that this occurs in Windows, no mention of Ubuntu. I actually get great power consumption with this system. I only use ~8watts at any given time when I'm not tethered to my AC power... It seems like the trickle charge is not working correctly perhaps? –  linux_RRT May 14 '12 at 17:38
    
No, what I was getting at was that I don't think that the consumption is really an issue, per se, since all of my testing on AC and on battery indicate a very low wattage at any given time. My highly variable capacity discrepancy seems to be the only thing that I have been able to pinpoint. What in Ubuntu is fundamentally measuring my battery capacity? I don't have any options in my BIOS regarding the battery at all, so I'm at a loss... –  linux_RRT May 14 '12 at 17:52
    
The BIOS is currently updated to the latest version from the link you gave mateo. I made sure to do this before I removed the old HDD and wiped it clean of Windows. The second question you asked about charge after shutdown: If the orange light is blinking when I shut the computer down, it persists after the computer is off. If I let the computer run for a little while without AC, the battery depletes a little and blinking goes away, at which point it does charge while powered off. But it seems to be using the same capacities that Ubuntu is using, and goes back to the blinking shortly after –  linux_RRT May 14 '12 at 18:16
    
Is the battery capacity the variable that controls when the system switches from charging to charged? Is it ACPI? I noticed something RE: ACPI - It is recognized as BAT1. in all of the posts that I researched most persons had a BAT0... what would happen if I changed the folder name (/proc/acpi/battery/BAT1 to BAT0? would this screw up all kinds of dependencies? And yes, thank you, I will look into it –  linux_RRT May 14 '12 at 18:35
add comment

Batteries lose capacity as they age. Even if they are not used, ie they are sitting on the shelf in a warehouse.

If the capacity you are seeing is about 85% of the design capacity I'd say that is not too bad for a battery with a year or so under its belt (though normally on a brand new battery you'd expect that to be a good amount higher).

Edit: given that this particular battery is brand new, and that the capacity seems to be dropping too fast, there may be a fault with the battery.

It is possible for a battery capacity to be, say 4400mAh by design, but to actually be 4480mAh when brand new, then drop to 3950mAh within the first year and a half. At any time, however, if you charge the battery fully to that amount, it should be reported as 100% charged (or 98%+, depending on the aggressivity of the charger), even if the capacity of the battery is only 89% that of the battery's design capacity. This is because the percentage charged should be reported as a percentage of actual capacity rather than design capacity.

At any rate, it isn't an Ubuntu issue. I mean, how much the charger charges the battery, when it stops charging, and how much the battery is capable of storing, isn't. How it's reported in Ubuntu might be, however. If you have reason to suspect that Ubuntu is actually reporting the battery capacity incorrectly, notwithstanding what I said above, then that is entirely possible.

Note too that all those stats the battery keeps are a best guess, and they are somewhat limited in their ability to accurately measure the amount of charge going in and out.

This answer may not have actually solved your problem buy hopefully it was still somewhat useful.

share|improve this answer
    
Well, I doubt that this problem is related to age, as this battery is brand spanking new (by new I mean < 1 month old). I let the computer on last night actually, and now the acpi -V is at 73%. I haven't removed the charger since it was last recognized at 86%. Are there any commands that I could issue to give you a better idea of the discrepancy that I'm seeing here? I was at about 4000 mAh before I went to sleep last night, and now I'm closer to 3000 mAh. I just don't know where to start in fixing this problem. –  linux_RRT May 14 '12 at 12:25
    
Also, the computer didn't have this flashing orange light before when it "thought" that the capacity had been reached. Before, when the full capacity was reached, it would change from a white light to no light at all. Now this ominious orange blinking is constant. –  linux_RRT May 14 '12 at 12:39
    
Another thing that I've noticed is that my indicator-battery in the unity panel reports that the battery is charging, while batmon reports that the battery is charged (not charging). Indicator-battery even gives me a "time until charged", but all of my other sources are telling me that the battery is not charging. Another instance of discrepancy between the estimation and what is actually occurring. –  linux_RRT May 14 '12 at 12:45
    
From all this info, there could be a fault with the battery. Good luck speaking with the manufacturer. It's possible the orange flashing light means a battery malfunction but I have no idea if that's the case with your laptop. –  neon_overload May 15 '12 at 0:36
    
I am hesitant to do a "answer my own question" but I have managed to get my battery percentage up to 95% again. What I did was drain the battery by 20%, remove the battery while ubuntu was loaded, powered down without the battery plugged in, putting the battery back in and letting the battery charge up while the system was powered down. The orange light is still blinking, but I have managed to recover some of that "lost capacity", so I'll keep trying it. It really does seem like it's not the battery causing this problem –  linux_RRT May 15 '12 at 3:13
add comment
up vote 1 down vote accepted

I'd like to thank everyone who contributed to this discussion, as it led me to a couple of ideas that I used when testing the charging method for this laptop. I am marking this solved only because I was able to get the battery to charge to 100% again... HOWEVER, I was unable to get the the root of the problem, and I doubt that this fix will work on other laptops. What I discovered regarding the trickle charge (thanks mateo and neon_overload) was that the energy provided during the time that the computer was on was ineffective in charging the battery, presumably because too much power was being provided to the system. When the battery is above 90% charge, there seems to be a safety mechanism built in that keeps the battery from charging too much, and it was being activated any time I tried to charge the laptop from above the measured 90%. To fix this, I drained the battery to 80% (of the measured capacity, not design capacity), and pulled the battery while the system was on. I then powered the system down and plugged the battery back in. This made the system avoid trickle charging and also avoid the safety mechanism that is built in. 20 minutes later the orange flashing light that I had been seeing disappeared, and the white charging light turned off, indicating that the battery had charged fully.
Thanks again for all of your help guys, it's much appreciated.

linux_RRT

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.