Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I had been using Ubuntu 11.10 with all the bells and whistles, every thing fine. I download and install the newest version of Ubuntu (12.04) and the webcam doesn't work. I tried installing cheese, but this application reports that it does not find any devices. Then I found a similar question here, but installing the application gave me the same error:

Guvcview error:
Unable to open device
Please make sure the camera is connected
and that the correct driver is installed.

I have an HP G60 with integrated webcam that worked perfectly under 11.10. What should I do?


share|improve this question

4 Answers 4

Procedure to install web cam in UBUNTU 12.04 LTS OS

First download the libwebcam0 files from Ubuntu one. then, enter the command : $ echo guvcview It will ask your root pass word: *** Give your pass word ,then it will unwrap required files itself. before that it ask the consumption of disk space ,Give Yes

After completion of this step give : guvcview libwebcam0

your web cam will activate.

share|improve this answer

I also had this problem with a webcam someone gave to me yesterday. It is USB device, a Genius iLook 320. Naturally there are windows and mac drivers, but nothing official about using it with Ubuntu.

Therefore, RTFM for guvcview. Open a terminal, and type

man guvcview

It says, among other things:

"-d, --device=VIDEO_DEVICE Video Device [default: /dev/video0]"

Make sure your webcam is attached. Then go to the terminal and enter the command:

ls /dev | grep -i video

The reply is:


Aha! The default device that guvcview uses, video0, DOES NOT EXIST!

Therefore, you must make guvcview use the device that exists, because that's where your webcam is.

at the terminal:

guvcview --device=video1 &

and it should work. If you run guvcview from the menu, edit the menu item, adding "--device=video1" The "&" is for running from the terminal. There are other command line options given in the man page, and I have not tried to figure out what they do yet.

When you run guvcview from the terminal, you will see a lot of messages about "ALSA lib" which is for sound (which my camera does not have), and other messages such as: "{ pixelformat = 'RGB3', description = 'RGB3' }" These messages might help you configure video quality.

The first time you run it, it will create a configuration file in your home directory: ~/.guvcviewrc-video1

You can edit this file as desired. The default picture quality of my device leaves a lot to be desired. YMMV.

share|improve this answer
I'd like to note that after I rebooted with the webcam attached, it was then on /dev/video0. –  Wastrel Apr 4 at 0:46

Similar experience, figured out a temporary workaround. You can find it posted here: The post's toward the end, it doesn't work 100% but if your problem is the same as mine it should help a bit.

share|improve this answer
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Eliah Kagan Sep 16 '12 at 14:33

Use guvcview and select video type as YV12. It will solve the problem.

share|improve this answer
It may help the person who asked the question if you could fill the answer with a bit more detail. This may then help other users who have similar problems. –  SimplySimon Jul 29 '13 at 13:45

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.