Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have already install a clean Ubuntu 12.04 in an Acer. After the installation, the wifi was not detected. I have followed several bcm431X tutorials (from this forum), but no-one worked out.

In summary, I have tried installing b43-fwcutter & firmware-b43-installer packages, and also, in first instance, bcmwl-kernel-source.

Here is the lspci output.

05:00.0 Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01)
    Subsystem: AMBIT Microsystem Corp. Device 0422
    Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0, Cache Line Size: 32 bytes
    Interrupt: pin A routed to IRQ 17
    Region 0: Memory at f0400000 (32-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel modules: ssb

What can I do to solve the problem?

Thanks in advice.

share|improve this question
    
See here → askubuntu.com/questions/38327/… –  Web-E May 14 '12 at 4:21
    
Already tried both solutions, but it is still not working –  fernando garcía May 14 '12 at 17:16
add comment

1 Answer 1

I had exactly same problem and I think I solved it. I had Travelmate 5520G with Vista and Ubuntu 10.10 installed and with wlan working good. Then I replaced the 10.10 with 12.04 so the problems started. I installed b43-fwcutter and stuff but the problem persisted.

The problem solved by shutting down the SLA-driver that was on by default in Ubuntu and rebooting the laptop to Vista. When running Vista, the wlan led was on and blinked once in a while. I pulled the wlan switch so the wlan connection and the led turned off. Next I rebooted the laptop. And now, against all predictions, wlan worked on Ubuntu 12.04. I am not 100% sure if shutting down the SLA-driver had any effect to the result but that is what I did before rebooting to Vista.

We are living in a mysterious world, fellas.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.