Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently bought a new laptop: Asus N55SL.

I've tried to run Ubuntu 10.04 LTS on it. I was extremely happy with it on my previous HP Pavillion 6195.

I have 5 partitions:

  1. ntfs win7 recovery partition
  2. ntfs win7 home premium OS partition
  3. ntfs data partition
  4. ext4 /
  5. ext4 /home
  6. swap (16 gigs)

Now: Ubuntu 10.04 LTS installs perfectly. But doesn't recognize most of the brand new peripherals: graphics card, wlan card, eth card.

I've been waiting patiently for the release of Ubuntu 12.04 LTS... If i boot from a live distro it works like a charm. Even the webcam gets recognized properly! but I don't manage to get installed on the disk properly!

Attempt tried:

  1. manually install the network card driver on 10.04 and do a distro upgrade -- failed
  2. install the live with the network connection enabled -- failed
  3. as .2 but without network
  4. install on a single ext4 partition without a separate /home -- failed

the installation freezes after writing about 2.1 GB on disk. The CPU start getting hot (fan speed raves high like crazy). If I force a shutdown with the power button I don't get grub loaded during boot.

Luckily if reinstall Ubuntu 10.04 back everything gets properly restored.

Thanks for helping.

share|improve this question
    
when you say 10.04 doesn't recognise the graphics card, what do you mean? does the screen not show up, does it drop you into a command line or something? –  jackweirdy May 13 '12 at 20:22
    
the screen resolution is 1920x1080. But I only get something like 1600x1200. If I boot 12.04 live I get the right screen resolution. I assume 10.04 doesn't come packed with the driver for the Intel HD Graphics card. I have a secondo card: but I know that at the time I bought the laptop the drivers for the NVidia GT 635M where not yet available. But the problem is not with Ubuntu 10.04, it did its great time for me. I would like to move over to 12.04. –  Andrea Borga May 13 '12 at 20:26
    
ok, since none yet posted help, I'll try if some further questions will help somebody to help me solving my problem: (i) is there a toll to debug the installation? (ii) is there an installation CD different from the Live distribution? –  Andrea Borga May 31 '12 at 9:46
1  
I'd try the alternate installer; it doesn't run with fancy graphics and its designed to run on lower memory/low compatability machines. download from cdimage.ubuntu.com/releases/12.04/release –  jackweirdy May 31 '12 at 15:07
add comment

1 Answer 1

up vote 1 down vote accepted

After a (rainy) Sunday afternoon of hacking I managed to find my own solution to the problem. Here is the method and the problem I pinned:

  • I discovered that if you click on the arrow next to the status information on top of the progress bar in the lower part of the installation screen you get a small terminal with a verbose description of the current installer operation
  • I partitioned the disk space reserved to Ubuntu in two Ext4 partitions: 50Gb for / and 40 GB for /home
  • Started the installation from the live USB with the network interface (WLAN) enabled without updates and third party packages installation
  • The installer downloaded a few packages (language packs I noticed) from the servers
  • copied correctly the files, started installing the system on disk, moved to configuring hardware
  • then moved back to "installing system" and started to erase loads of packges from the disk! Seems like it tries to wipe out everything it copied earlier! It start prompting errors while trying to erase the dpkg package (for obvious reasons)
  • First fatal error says: RSYSLOG-2177: IMUXSOCK begins to drop messages from PID 17950 due to rate limiting
  • followed by: UBIQUITY: select at least one PAM profile from the list
  • game over

To solve the problem I installed back 10.04 LTS, manually installed the atheros network card driver, connected the new laptop to the old laptop, shared its internet connection and fired a distribution upgrade with "update-manager -d". It took almost 1h30min but now my Ubuntu 12.04 LTS works like a charm! All peripherals are recognized and behave as they should (so far).

I hope this will help others.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.