Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have both 12.04 and 11.10 installed on the same machine. Internet (both wireless and wired) isn't working on 12.04. Any help?

lshw -C network

PCI (sysfs)  
  *-network               
       description: Ethernet interface
       product: 82567LF-2 Gigabit Network Connection
       vendor: Intel Corporation
       physical id: 19
       bus info: pci@0000:00:19.0
       logical name: eth0
       version: 00
       serial: 00:21:9b:1b:9e:31
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=1.5.1-k firmware=1.8-5 latency=0 link=no multicast=yes port=twisted pair
       resources: irq:43 memory:f9dc0000-f9ddffff memory:f9df4000-f9df4fff ioport:a080(size=32)
  *-network
       description: Wireless interface
       product: AR5418 Wireless Network Adapter [AR5008E 802.11(a)bgn] (PCI-Express)
       vendor: Atheros Communications Inc.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 01
       serial: 00:22:b0:ce:f1:ff
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=3.2.0-24-generic firmware=N/A ip=192.168.1.129 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:16 memory:f9ef0000-f9efffff

IWCONFIG

lo        no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"FASTWEB-1-bztAlI1hzEaT"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: D4:D1:84:02:F0:80   
          Bit Rate=54 Mb/s   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=52/70  Signal level=-58 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:914   Missed beacon:0

eth0      no wireless extensions.
-
share|improve this question
    
The outputs above show that you are connected to a wireless AP. What do you mean by not working? –  mikewhatever May 13 '12 at 20:44
    
I meant it's not connecting to any webpage –  memecs May 18 '12 at 15:56

1 Answer 1

The problem turned out to be related to DNS look-ups. My system couldn't display websites because it wasn't able to look up their IP information via my DNS servers.

This was solved by resetting /etc/resolv.conf to:

# Use Google DNS
nameserver 8.8.8.8
nameserver 8.8.4.4
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.