Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I face crossplatformui errors when I install the crossplatformui application for mts mblaze wireless broadband modem. On a forum I learnt that the error was because the package needed a kernel version lower than 2.6 whereas I use Ubuntu 12.04 the kernel version being 3.2.0.24

So I want to know where I could find

  1. A compatible crossplatformui package for the kernel version 3.2.0.24

  2. A safe way to remove crossplatformui other than editing the dpkg status file which did work once but caused a big problem lately. I would like to know a safer and better way to remove/purge it

share|improve this question

2 Answers 2

Answer #1. I'm sorry I have the same situation here.

Answer #2. In my experience, you don't have to edit the dpkg status to remove it. Here's what I did:

  1. Enter /var/lib/dpkg/info

    cd /var/lib/dpkg/info
    
  2. Delete all entry related to crossplatformui

    sudo rm crossplatformui.*
    
  3. Force remove crossplatformui

    sudo dpkg --remove --force-remove-reinstreq crossplatformui
    
    (Reading database ... 
    dpkg: warning: files list file for package `crossplatformui' missing, assuming package has no files currently installed.
    
    (Reading database ... 159448 files and directories currently installed.)
    
    Removing crossplatformui ...
    
  4. Done! I didn't experience any problem with my system (Ubuntu 12.04 with kernel 3.2.0-24-generic-pae) by doing this method.

Cheers!

share|improve this answer
    
Welcome to Ask Ubuntu! This seems like it is, at least in part, an answer to the question, but it's worded as though you're asking a separate, related question. To make this clearer for people searching for help (so they know this post might help them), and to decrease the likelihood that this post will be considered not-an-answer and deleted, I recommend rewording this, and also removing anything that is actually a question (rather than a proposed solution) and posting it as a new question. –  Eliah Kagan Jul 3 '12 at 0:33

CrossPlatformUI works along with CDMA modem switcher.

I got this from a Indonesian website which I don't remember right now. It works for me. Only thing is you have to make sure the version of CrossPlatformUI you are using identifies your data card.

Crossplateform works even if it is not properly installed. It works for me so it will work for you. My version is 2.0.6.

I hope this help.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.