Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to install Transmission 2.51 on Ubuntu 10.04. Compiling the source goes fine, but I can't seem to get it to compile the GUI as well. This is the configure output:

Configuration:

   Source code location:                              .
   Compiler:                                          g++

   Build libtransmission:                             yes
      * optimized for low-resource systems:           no
      * µTP enabled:                                  yes

   Build Command-Line client:                         yes

   Build GTK+ client:                                 no (GTK+ none)
      * libappindicator for an Ubuntu-style tray:     no

   Build Daemon:                                      yes

   Build Mac client:                                  no

How do I get it to build the GTK+ client?

share|improve this question

4 Answers 4

up vote 3 down vote accepted

Looking at the ./configure file reveals the following:

##
##
##   MANDATORY for the GTK+ client
##
##

GTK2_MINIMUM=2.22.0

GTK3_MINIMUM=3.2.0

GLIB_MINIMUM=2.28.0

GIO_MINIMUM=2.26.0

Looking at the lucid packages, GTK2 currently is 2.20. Since GTK2 is so fundamental to all of Lucid applications, I would not recommend that you try to uplift your GTK version (it will require a major recompile of all sorts of stuff).

You cannot simply reduce those minimum version values - I've tried... the compilation will fail because the code requires the newer GTK libraries.

If you want a relatively newer version (v2.33) that will work with Lucid, can I suggest this ppa:

sudo add-apt-repository ppa:transmissionbt/ppa
sudo apt-get update
sudo apt-get install transmission

Run transmission-gtk reveals:

enter image description here

share|improve this answer
    
So what you're saying is that anything newer than Transmission 2.33 isn't compatible with the stable releases of Ubuntu, so I can't have the features I need from Transmission 2.51 without upgrading to a newer version of Ubuntu which will most probably break most of the other applications I'm using. That's just **** great –  Hubro May 13 '12 at 21:44
    
... correct ... the developers like playing with newer shiny stuff... hence older stable OS's can only be upgraded to the latest version if the developers themselves have decided they support it. In this case - they only support GTK+2.22 onwards. –  fossfreedom May 13 '12 at 21:47

Getting latest transmission-gtk to build and run on Ubuntu 10.04 is possible, but hard and cumbersome due to the gtk dependancy. Getting it themed right may also be messy. You might want to consider just going with the daemon, and control it with the webui and/or one of the many third-party rpc clients. There's a PPA which currently has version 2.60, for Ubuntu 10.04, of all the clients except the gtk client: ppa:transmissionbt/nogtk

share|improve this answer

You can install the required development tools with this command

sudo apt-get install build-essential automake autoconf libtool pkg-config intltool libcurl4-openssl-dev libglib2.0-dev libevent-dev libappindicator-dev

Then compile with

tar xvjf transmission-2.51.tar.bz2
cd transmission-2.51
./configure -q --with-gtk --enable-daemon --with-inotify --enable-nls && make -s
su
make install

share|improve this answer
    
E: Couldn't find package libminiupnpc-dev –  Hubro May 13 '12 at 16:10
    
dont install it you will already be having libupnp3 & libupnp-dev ... edited my answer –  Ashu May 13 '12 at 16:34
    
Still says "Build GTK+ client: no (GTK+ none)". Additionally, this warning appears: "configure: WARNING: unrecognized options: --enable-gtk, --enable-libnotify" –  Hubro May 13 '12 at 16:37
    
srry wrong argument... again edited –  Ashu May 13 '12 at 17:22
    
configure: error: "GTK+ not found!" –  Hubro May 13 '12 at 17:34

You need to have the package libgtk-3-dev.

Otherwise the compiling process will break with this message:

configure: error: Package requirements (gtk+-3.0 >= 3.2.0
                              glib-2.0 >= 2.32.0
                              gio-2.0 >= 2.26.0,
                              gmodule-2.0 >= 2.32.0
                              gthread-2.0 >= 2.32.0) were not met:

No package 'gtk+-3.0' found

You just need to install it with:

sudo apt-get install libgtk-3-dev
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.