Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I run Ubuntu Desktop in a VirtualBox seamless mode, hosted on Windows 7. I recently upgraded from 11.10 to 12.04 and seamless mode no longer works correctly. I have re-installed guest extensions.

The problem is that the Ubuntu desktop wallpaper is shown, effectively blocking the Windows desktop. I can bring Windows apps to the foreground, but as soon as I bring any Ubuntu window to the foreground, all the windows apps will disappear, hidden by the ubuntu desktop even if I activated an Ubuntu window in a different monitor. So, it is not very much different from full-screen mode at this time.

I suspect if I could turn off the Ubuntu desktop or wallpaper this would be a sufficient workaround (this is basically what Seamless mode is) but that does not seem to be possible within Ubuntu itself.

[Jeremy doesn't specify system config, but I can confirm I'm seeing this behavior in Win 7 64-bit with both 32-bit and 64-bit guests. Giovanni sees the same thing on his laptop running Vista Ultimate 64 bit after upgrading his 32-bit guest to 12.04 (forums.virtualbox.org p225407, requires logging in with your free Oracle account). I was using vbox 4.1.14r77440 and matching Guest Additions. I upgraded to 4.1.16-78094 vbox+additions. Still a problem. And I filed launchpad bug 999929 to see if I can get feedback from developers. – tbc0]

Any other ideas?

share|improve this question
add comment

5 Answers

up vote 8 down vote accepted

This appears to be a window manager issue. As a VirtualBox guest under Windows 7 Premium 64-bit, Ubuntu 12.04 64-bit has the problem mentioned: the Ubuntu background image remains displayed. Using Ubuntu 12.04 64-bit with the GNOME window manager (installed via Ubuntu Software Center), however, seamless mode works correctly. Using Xubuntu 12.04 64-bit (which uses the XFCE window manager instead of Unity), the seamless mode also works correctly. Thus only Unity experiences this problem.

Until the Unity team solves the issue, use the Ubuntu Software Center and type in 'gnome' and use it to install the GNOME Desktop Environment. At log-in time, click on the Ubuntu icon and select one of the GNOME choices [GNOME, GNOME Classic, or GNOME Classic (no effects)] for your session. Seamless mode works as intended.

Alternatively, use the Xubuntu distribution. Seamless mode also works as intended.

share|improve this answer
add comment

I installed gnome desktop, problem's still there. But this works to me: enter full screen mode --> log out ubuntu --> now full screen mode renders correctly and seamless mode back to normal.

share|improve this answer
add comment

Power off the VM and then boot it back up and log back in. It will work.

share|improve this answer
1  
It seems to be a much greater problem, across many clients and over a period of time. –  fabricator4 Dec 22 '12 at 4:28
add comment

Enable 3D in the Virtual Box Machine Display Settings. You will need to shutdown or power off your virtual machine first.

Without it, seems to make it that the guest's background and all appears. It's basically full screen but with the host's HUD stuff visible.

Host: Windows 7 64bit Guest: Ubuntu 12.04

share|improve this answer
    
Where in the settings can you enable 3D acceleration? (In addition to text describing this, a screenshot would probably also be helpful.) –  Eliah Kagan Oct 6 '12 at 12:11
    
puu.sh/1i98R cant inline an image here :( heres the screenshot –  WilliamStam Oct 24 '12 at 7:45
    
This solution worked as intended for me, without 3D I had no way to get into seamless mode –  Matteo Apr 8 at 11:42
add comment

Installing any desktop environment like xdm, kdm, lightdm and gnome makes things work. I had a tough time figuring this out but now I have a smooth seamless mode working on my Win7 host with Ubuntu 12.04 guest.

share|improve this answer
1  
A display manager (default is lightdm) is always installed with desktop version of Ubuntu. Your answer isn't really answering the question –  Anwar Shah Oct 12 '12 at 15:30
add comment

protected by fossfreedom Nov 26 '13 at 12:44

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.