Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Ubuntu 12.04 64bit Desktop

I am connecting to my home Wi-fi using wep key, like I do with all of my other devices. There is no issue with the wi-fi as none of my other devices have this problem.

Every 5 minutes give or take, I will get a request to enter the WEP key for my network. even though I am connected with no problems. Through trial an error I have learnt that choosing either connect, or cancel will give exactly the same result. Another notification saying Wireless disconnected - Yet I am still connected, everything is working. I just continually get the request to enter my WEP key, I am connected the whole time, despite the alerts I receive. Its quite irritating having to have to stop working on whatever I am working on at the time, every 5 minutes just to get rid of the WEP key pop up.

I have also checked my drivers, I have the correct one for my wireless. and it is working and active.

Has anyone else had this issue and know how to resolve it? Hope someone can help.

Cheers

share|improve this question

2 Answers 2

up vote 0 down vote accepted

It sounds like the settings aren't saving properly; open up the network connections menu (you can find it in the dash search menu) and move to the wireless tab. Remove the connection which has been created, click the add button and enter the settings for your wireless network. Click save and try restarting the machine.

share|improve this answer
    
That seems to have worked thanks :) Haven't had it ask for my WEP key yet since I did that. –  Josh May 13 '12 at 15:10

I had the same thing happen to me on a dist upgrade from 10.04 to 12.04.

The wireless worked fine in 10.04 then after the upgrade it kept asking for the wep key every 30 seconds. But the network would work in that 30 seconds. Frustrating. I found this answer and found a bit of a faster way to get things going.

First, open up the drawer, type in Network Tools. Then open Network Tools, switch it to the WLAN and click Configure. Finally in the Wireless tab, find the "auto" connection, highlight it and click Edit. then go to Security, and enter the key there. Click Save and it's done.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.