Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I connect my Sony PRS-T1 e-reader Ubuntu 12.04 opens the Removable Media's default photo app (Shotwell) and then displays the contents of one of the two drives: /Media/Setting. The other drive is /Media/Reader. Both drives are mounted in the launcher, btw.

The only obvious way to prevent the above is to check "Never prompt or start media upon insertion" in System Settings / Details / Removable Media. But then I have to go without automatic launching of apps for CDs, DVDs and photos.

I'd like the e-reader to open Calibre (and also keep the other automagic stuff) but without the annoying aberrations. Does anyone know how?

I've read that I could add an empty document entitled .is_audio_device to the root of an MSC which will tell Ubuntu to open a USB stick, for example, as an audio device. Could I do the same with the ereader? But what would the title be? Would it be .is.ebook_device or .is.ereader_device or something else?

Thanks for your help.


share|improve this question

As a temporary solution I disabled automount-open in Dconf: org/gnome/desktop/media-handling and also set Removable Media's Photos to "Do Nothing". At least now plugging in the e-reader won't open Shotwell or display the contents of the drives.

As to how to get the e-reader to be recognised as an e-reader and not a camera, and then to open Calibre automatically....

share|improve this answer
I know it's not the done thing to repeatedly answer your own questions. However, I thought someone might like to know that you can use Cuttlefish to open Calibre when your e-reader mounts. Having disabled all automounts I also added two additional instructions: an MP3 player launches Banshee, and a camera launches Shotwell. Bit of a clumsy workaround but better than nowt. – Bingo Bones Sep 14 '12 at 17:43

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.